jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philippe Mouawad <philippe.moua...@gmail.com>
Subject Re: Remote Start
Date Tue, 24 Jan 2017 19:29:07 GMT
On Fri, Jan 20, 2017 at 8:01 PM, Hohmann, Kurt D <khohmann@navisite.com>
wrote:

> Problem: Scripts work fine when run on the primary machine, but not when
> run from remote agents.
>
> Background: I'm running a Windows Server (2008R2) with remote agents on
> RedHat Linux 6 machines. Everything is running JMeter at version 3.1. I've
> made appropriate and identical Hosts file entries on the Windows box and
> the Linux boxes, and verified that I can manually browse to my test site in
> all locations via browser. Linux boxes are running jmeter-server. All
> machines reside in the same domain.
>
Did you check connectivity between servers (jmeter-server <=> jmeter
client) ?

>
> Details: I'm using a Results Tree listener for troubleshooting. Pages
> appear to be working correctly (I'm seeing response code "200" in the
> Sampler result tabs) BUT - there is nothing displayed in any of the
> Response Data tabs. As I'm extracting  response data for login operations
> (e.g. JSESSIONID, VIEWSTATE), I'm never really getting logged in.
>

In distributed mode JMeter since 2.9 strips responses data for scalability.
If you need those for debugging, just put in user.properties:

mode=Standard

But switch back to default mode for your load test.

>
> Any thoughts on further troubleshooting would be greatly appreciated.
>
> Thanks,
> Kurt
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
> For additional commands, e-mail: user-help@jmeter.apache.org
>
>


-- 
Cordialement.
Philippe Mouawad.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message