jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From o haya <oh...@yahoo.com.INVALID>
Subject Trying to setup test plan for Oracle Database
Date Tue, 06 Dec 2016 20:21:00 GMT
Hi,

I'm just starting to try to setup a test plan for testing Oracle Database using Jmeter 3.1.
 The Jmeter is running on Windows.

I have setup the test plan with:

Thread Group
    - JDBC Connection Configuration
    - JDBC Request
    - View results in tree

I have added ojdbc.jar to the Jmeter's 'lib' directory

For the JDBC Connection Configuration, I have:
Variable Name: mydb

Validation Query: select * from dual;

Database URL: jdbc.oracle:thing:@//myhostname:myhostport/mysid
Username: <db username>
Password: <db password>



For the JDBC Request I have is:
Vraiable name: mydb
Query Type: Select
Query has: select * from departments;

Handle Result Set:  Store as string (this is grayed out)



When I run the test plan I am getting:

Sampler result:
Thread Name: Thread Group 1-1
Sample Start: 2016-12-06 15:18:03 EST
Load time: 33
Connect Time: 33
Latency: 0
Size in bytes: 84
Sent bytes:0
Headers size in bytes: 0
Body size in bytes: 84
Sample Count: 1
Error Count: 1
Data type ("text"|"bin"|""): text
Response code: null 0
Response message: java.sql.SQLException: Cannot create PoolableConnectionFactory (ORA-00933:
SQL command not properly ended
)

Response headers:

SampleResult fields:
ContentType: text/plain
DataEncoding: UTF-8



Request: [Select Statement] select * from departments;




Response: Cannot create PoolableConnectionFactory (ORA-00933: SQL command not properly ended
)




I have tried a bunch of things, but cannot eliminate this error.  Can anyone tell me why this
error is occurring?

Thanks!

Jim

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
For additional commands, e-mail: user-help@jmeter.apache.org


Mime
View raw message