jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From o haya <oh...@yahoo.com.INVALID>
Subject Re: Trying to setup test plan for Oracle Database
Date Tue, 06 Dec 2016 20:42:24 GMT
Hi,

Thanks for your help.  Got it working.

To repeat, if I leave out the Validation query, I get an error (that was just to kind of make
it clear).

For Validation query, I have to have:  

select 1 from dual   --> with NO ending semi-colon



For the JDBC query, I have to have:  

select * from departments   --> with NO ending semi-colon



Now it works.  Picky, picky :)!!


Now I have to setup some loops or something with different users.


Thanks!

Jim








--------------------------------------------
On Tue, 12/6/16, Felix Schumacher <felix.schumacher@internetallee.de> wrote:

 Subject: Re: Trying to setup test plan for Oracle Database
 To: user@jmeter.apache.org
 Date: Tuesday, December 6, 2016, 3:37 PM
 
 Am 06.12.2016 um 21:34
 schrieb o haya:
 > Hi,
 >
 > Validation Query:
 >
 > Hmm.  I got a
 different error if I leave this out, and yes, that was a
 typo on my part.  I already had it as:
 >
 > select 1 from
 dual;
 Can you post the error you get? (The
 isValid method is relatively new, 
 so you
 should use a recent oracle jdbc driver. I think that should
 be 
 ojdbc6.jar)
 >
 >
 >
 >
 About the URL, yes, again, my typing error here, it was
 already a ":"
 >
 >
 > So still getting the
 same error, but don't know why.  I remember doing this
 (Jmeter+Oracle ) a long long time ago, and don't
 remember it being this difficult, plus I am following most
 of my old notes.
 Have you removed the
 semicolons?
 
 Do you have any
 error/warning logs in jmeter.log?
 
 Felix
 >
 >
 Thanks,
 > Jim
 >
 >
 >
 >
 >
 --------------------------------------------
 > On Tue, 12/6/16, Felix Schumacher <felix.schumacher@internetallee.de>
 wrote:
 >
 >   Subject: Re: Trying to setup
 test plan for Oracle Database
 >   To: user@jmeter.apache.org
 >   Date: Tuesday, December 6,
 2016, 3:27 PM
 >   
 >   Am 06.12.2016 um 21:21
 >   schrieb o haya:
 >   > Hi,
 >   >
 >   > I'm just starting
 >   to try to setup a test plan
 for testing Oracle Database
 >   using Jmeter 3.1.  The
 Jmeter is running on Windows.
 >   >
 >   > I have setup the test
 >   plan with:
 >   >
 >   > Thread
 >   Group
 >   >      - JDBC
 Connection
 >   Configuration
 >   >      - JDBC
 Request
 >   >      -
 View results in tree
 >   >
 >   > I have added
 >   ojdbc.jar to the Jmeter's
 'lib' directory
 >   >
 >   > For the JDBC
 >   Connection Configuration, I
 have:
 >   >
 >   Variable Name: mydb
 >   >
 >   > Validation Query: select
 * from dual;
 >   With 3.1 you
 can leave the validation query
 >   empty and the pool will
 try
 >   to use the jdbc
 >   method isValid to validate
 the connection. If you want
 >   to specify a validation query
 by hand, the
 >   usual query
 for oracle is
 >   "select
 1
 >   from dual".
 >   >
 >   >
 >   Database URL:
 >   jdbc.oracle:thing:@//myhostname:myhostport/mysid
 >   The . between jdbc and oracle
 looks like a
 >   typo, I think
 there should be
 >   a colon
 and
 >   the "thing"
 is probably a typo and should be
 >   "thin", right?
 >   > Username:
 >   <db username>
 >   > Password: <db
 >   password>
 >   >
 >   >
 >   >
 >   > For the JDBC Request
 >   I have is:
 >   > Vraiable name: mydb
 >   > Query Type: Select
 >   >
 >   Query has: select * from
 departments;
 >   >
 >   > Handle Result Set:
 >   Store as string (this is
 grayed out)
 >   >
 >   >
 >   >
 >   >
 >   When I run the test plan I am
 getting:
 >   >
 >   > Sampler result:
 >   > Thread Name: Thread
 Group 1-1
 >   > Sample
 Start: 2016-12-06 15:18:03 EST
 >   > Load time: 33
 >   > Connect
 >   Time: 33
 >   > Latency: 0
 >   > Size in bytes: 84
 >   >
 >   Sent bytes:0
 >   > Headers size in
 bytes:
 >   0
 >   > Body size in bytes:
 84
 >   > Sample Count: 1
 >   > Error
 >   Count: 1
 >   > Data type
 >   ("text"|"bin"|""):
 text
 >   > Response code:
 null 0
 >   >
 >   Response message:
 java.sql.SQLException: Cannot create
 >   PoolableConnectionFactory
 (ORA-00933: SQL command not
 >   properly ended
 >   > )
 >   >
 >   > Response headers:
 >   >
 >   > SampleResult
 >   fields:
 >   > ContentType:
 text/plain
 >   >
 DataEncoding: UTF-8
 >   >
 >   >
 >   >
 >   > Request: [Select
 >   Statement] select * from
 departments;
 >   >
 >   >
 >   >
 >   >
 >   >
 >   Response: Cannot create
 PoolableConnectionFactory
 >   (ORA-00933: SQL command not
 properly ended
 >   > )
 >   >
 >   >
 >   >
 >   >
 >   > I have tried a bunch
 >   of things, but cannot
 eliminate this error.  Can anyone
 >   tell me why this error is
 occurring?
 >   Have
 >   you tried to remove the
 semicolons at the end of your
 >   statements?
 >   
 >   Felix
 >   >
 >   > Thanks!
 >   >
 >   > Jim
 >   >
 >   >
 >   ---------------------------------------------------------------------
 >   > To unsubscribe, e-mail:
 user-unsubscribe@jmeter.apache.org
 >   > For additional commands,
 e-mail: user-help@jmeter.apache.org
 >   >
 >   
 >   
 >   ---------------------------------------------------------------------
 >   To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
 >   For additional commands,
 e-mail: user-help@jmeter.apache.org
 >   
 >   
 >
 >
 ---------------------------------------------------------------------
 > To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
 > For additional commands, e-mail: user-help@jmeter.apache.org
 >
 
 
 ---------------------------------------------------------------------
 To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
 For additional commands, e-mail: user-help@jmeter.apache.org
 
 

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
For additional commands, e-mail: user-help@jmeter.apache.org


Mime
View raw message