jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Michaud <Bruno.Mich...@cn.ca>
Subject RE: Scripting a new-user signup
Date Thu, 02 Apr 2015 15:12:21 GMT
That's very hard to say without actually seeing the script and results. Looks like the variable
didn't get set prior to the POST invocation.
1- Make sure the name of the variable is *exactly* what you put in your extractor
2- Make sure the Sampler that executes the extractor actually runs *before* the POST
3- How do you specify that value in the POST ? is it a "parameter sent with the request" or
do you make it part of the URL, in which case you may be getting "encoded" as shown by your
literal. 

Bruno
-----Original Message-----
From: Bob Nance [mailto:bob.nance@novationsys.com] 
Sent: Thursday, April 02, 2015 10:55 AM
To: JMeter Users List
Cc: jmeter-user@jakarta.apache.org
Subject: Re: Scripting a new-user signup

I thought I had the format for the VAR substitution as ${reference name} but I sent the ${enrollment_id}
and it put in the literal "%24%7Benrollment_id%7D”

That would explain why the counter is not working, either.

How do I reference the variable in the POST?


> On Apr 2, 2015, at 9:46 AM, ZK <stevesenior69@gmail.com> wrote:
> 
> Hi,
> Add a 'View Results Tree' Listener to your test
> 
> Edit>Add>Listener>View Results Tree
> 
> 
> 
> ZK
> 
> 
> 
> --
> View this message in context: 
> http://jmeter.512774.n5.nabble.com/Scripting-a-new-user-signup-tp57220
> 68p5722073.html Sent from the JMeter - User mailing list archive at 
> Nabble.com.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
> For additional commands, e-mail: user-help@jmeter.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
For additional commands, e-mail: user-help@jmeter.apache.org
Mime
View raw message