jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marijn Wijbenga <Marijn.Wijbe...@cgpbooks.co.uk>
Subject Test Script Recorder XML Regex Matching
Date Fri, 19 Sep 2014 15:45:43 GMT
Hi,

I have an issue, which might well be a potential bug, where a posted value is not being matched
by the Test Script Recorder's Regex Matching functionality.

The request I'm recording has a post value containing XML (SAML token to be exact) which I'd
like to replace with a variable automatically.

For testing purposes I have configured a User Defined Variable (called TEST) with a value
of "(?s)^.*$", I've tried "^.*$" and ".*" as well (all without double quotes).

Only ".*" replaces the content with this: <${TEST}>

I've tried other expressions as well and I'm able to match anything within the <> characters,
but not those characters itself.

Does anyone else have experienced the same thing, or is this a known issue? Or should I post
this in the developer's mailing list?

Cheers

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message