jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Erlewein <oli...@erlewein.net>
Subject Re: If Controller working in wondrous ways (or not)
Date Wed, 13 Aug 2014 22:53:49 GMT
Hi,

@Philippe: The jmeter.log shows nothing (i.e. no error). I'll switch it to
DEBUG level and see what happens.  The Debug Sampler always shows the
correct values for the variable. I'll need to have a think how I can
simulate this in a simple script to share here.

@Shmuel: Yes, been there done that. I tried both, string and integer
comparisons...

Cheers Oliver


On 13 August 2014 17:36, Philippe Mouawad <philippe.mouawad@gmail.com>
wrote:

> Hello,
> Did you check jmeter.log for errors ?
> Could you create a simple test plan using debug sampler to show issue if it
> is?
>
> Try displaying with debug sampler the value of ${QuoteRequestID_matchNr}
>  before IfController.
> Regards
>
> On Wednesday, August 13, 2014, Oliver Erlewein <oliver@erlewein.net>
> wrote:
>
> > Hi all,
> >
> > So I've been fighting the If Controller for the last days (Ubuntu 64 bit,
> > Java 1.7 64bit, JMeter 2.11). I have to queries that basically simulate
> an
> > If...then...Else.
> > ${QuoteRequestId} is populated by a regexp from the previous call.
> >
> > 1) If Controller: ${QuoteRequestID_matchNr} > 0
> > Do some steps.
> >
> > 2) If Controller: ${QuoteRequestID_matchNr} < 1
> > Do some steps.
> >
> > Both have no ticks in Variable Expression and Evaluate for all children.
> 1)
> > works and 2) doesn't. Nothing I tried with 2) worked. Testing for other
> > stuff, using javascript, jexl,...
> >
> > What is going on? This is not the only time I've had this. IF Controller
> > seems to work only sporadically.
> >
> > Cheers
> > Oliver
> >
>
>
> --
> Cordialement.
> Philippe Mouawad.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message