jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philippe Mouawad <philippe.moua...@gmail.com>
Subject Re: Connection Timed out - Jmeter 2.4
Date Tue, 12 Aug 2014 06:35:37 GMT
Hello,
JMeter 2.4 is pretty old now.
The first thing you should do is upgrade to 2.11 and use last version of
either jdk6 or 7.

You error look like server javing issues on SSL , could it be explained by
upgrade of server libs ?

Try with more recent versions and see..
Read this before:

- http://s.apache.org/azdzalkd

Regards
@philmdot
On Monday, August 11, 2014, Charles Richard <charles.r@thelearningbar.com>
wrote:

> Hi,
>
> I've run into an issue that I'm not really sure how to troubleshoot anymore
> and any new ideas would be appreciated.
>
> I am using Jmeter 2.4 . I'm not sure I am at liberty to send my .jmx script
> along as it might be too much public information so I'll just try to
> explain the issue.
>
> I have this test that I'll run for performance testing of our website that
> will have users log in, submit some forms and then log out.
>
> Our servers are Red Hat 5 for the web servers and Jmeter runs on Red Hat 6.
> All traffic is kept internal to the network where the website servers are
> located.
>
> This test has always worked fine up until recently. Now, if I go through
> SSL, I get the following:
>
> Response code: Non HTTP response code: javax.net.ssl.SSLException
> Response message: Non HTTP response message: SSL peer shut down incorrectly
>
> javax.net.ssl.SSLException: SSL peer shut down incorrectly
>     at com.sun.net.ssl.internal.ssl.
> InputRecord.readV3Record(InputRecord.java:408)
>     at com.sun.net.ssl.internal.ssl.InputRecord.read(InputRecord.java:360)
>     at com.sun.net.ssl.internal.ssl
> .SSLSocketImpl.readRecord(SSLSocketImpl.java:7
>
> If I go through regular port 80, I get the following:
>
> java.net.ConnectionException: Connection Timed out.
>
> This will only happen to about < 2% of requests and the type of request is
> varied: image, .htm file that calls some Java Spring logic, etc.
>
> I thought this might be due to me re-arranging our Apache configuration but
> I tried reverting to prior settings and this still happens.
>
> It feels like some kind of server, network issue but I'm not sure how to
> troubleshoot it further at this point.
>
> I have tried to simplify the test by eliminating the log in process and
> just hitting the log in form and that is fine. I then reduced the test to
> logging in, just submitting one form and logging out and this has the same
> socket issues.
>
> Any suggestions on how to troubleshoot this further?
>
> Our servers are with a hosted company and I've submitted a ticket to them.
> They told me to check somaxconn I believe it was but this did nothing.
>
> Thanks,
> Charles
>


-- 
Cordialement.
Philippe Mouawad.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message