jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "张为东(为东)" <weidong....@alibaba-inc.com>
Subject 答复: JMeter sends https request delayed due to netbios lookup
Date Tue, 26 Aug 2014 13:28:14 GMT
Shmuel, I’d like to figure out the reason why JMeter sends netbios lookup 3 times in this
case.

 

On the other hand, I think it’s not related to the connection timeout, the server side works
well, the client side cost more seconds to send next packet.

 

发件人: Shmuel Krakower [mailto:shmulikk@gmail.com] 
发送时间: 2014年8月26日 21:09
收件人: JMeter Users List; 张为东(为东)
主题: Re: JMeter sends https request delayed due to netbios lookup

 

As you can see - it failed to connect the destination host.

You should be able to control the connect part to timeout if it doesn't get a valid connection
in a shorter time via the Connect Timeout:

http://jmeter.apache.org/usermanual/component_reference.html#HTTP_Request




Shmuel Krakower.

www.Beatsoo.org - re-use your jmeter scripts for application performance monitoring from worldwide
locations for free.

 

On Tue, Aug 26, 2014 at 3:17 PM, 张为东(为东) <weidong.zwd@alibaba-inc.com> wrote:

Hi Experts,

 

I encountered one issue that when JMeter sends a https request to server, it cost mostly 4
seconds during the session, it’s too long……. I had captured the packet data by wireshark,
you can have a look below or attachment.

 

Source IP(https client-JMeter):10.68.33.195

Destination IP(https server):10.125.199.69

 

For packet #1037, #1252 and #1404, JMeter tried 3 times to do netbios lookup, it cost 3 seconds,
it’s unexpected for me;

But the server side handle the https request quickly, it cost around 0.1s, it’s expected
for me.



 

Thanks,

Weidong



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
For additional commands, e-mail: user-help@jmeter.apache.org

 


Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message