jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From S L <slouie.at.w...@gmail.com>
Subject Using HTTP Script Recorder on JMeter 2.10 and 2.11 on Darwin
Date Fri, 21 Feb 2014 01:25:47 GMT
Hi,
I'm having trouble starting a proxy server for jmeter 2.10 and 2.11.  I
found a couple links on stack overflow and apache.org on this issue but my
error message is slightly different that what's written on these links.
 Per the wiki from apache.org, I don't think I have trouble finding
`keytool` because it returns the path when I do a

$ which keytool
/usr/bin/keytool

and  I don't have trouble creating a file in the jmeter-210 and
jmeter-211/bin dirs.  This is the error message I get in my jmeter.log file:

ERROR - jmeter.protocol.http.proxy.ProxyControl: Could not initialise key
store java.io.IOException: Command :'"keytool" "-genkeypair" "-alias"
":root_ca:" "-dname" "CN=_ DO NOT INSTALL unless this is your certificate
(JMeter root CA), OU=Username: COMPANY\user.name, C=US" "-keyalg" "RSA"
"-keystore" "proxyserver.jks" "-storepass" "randomstr1" "-keypass"
"randomstr1" "-validity" "7" "-ext" "bc:c"' failed, code: 1
keytool error: java.io.IOException: Invalid escaped character in AVA: 's'

I don't know what this "invalid escaped char in AVA" is.  My company and
username don't have the string "AVA" and I didn't find it in any of the
property files in jmeter-21x/bin.

Not sure if this is affecting it but I'm running jmeter from Darwin on a
MBP, OSX 10.7.5.
JMeter 2.9 doesn't give me any proxy issues, although, I ran into other
issues with it, which is why I tried using these 2 newer versions, which
are giving me problems with the proxy server.  I'll try going down to 2.8
to see what happens but I'd rather not if I can help it.  That and I'm
super curious what the issue is with 2.1x and my laptop.  Thanks in advance
for your help.

Links I found:
http://stackoverflow.com/questions/19550472/jmeter-2-10-http-recorder-throws-keytool-exception
https://wiki.apache.org/jmeter/TestRecording210

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message