jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Using JMeter to test JUnit
Date Sat, 05 Jan 2013 16:15:45 GMT
On 17 December 2012 13:50, masood ghasemzadeh <masood.ghz@gmail.com> wrote:
> Hi everybody,
>
> I'm trying to use my JUnit classes in JMeter. These classes are Web Service
> Client and the main class which invoke some of the methods of my Web
> Services. Here is what I did:
>
> 1. Made a Web Service Client (I do it by using Netbeans WS-Client generator)
> 2. Wrote another class which extends junit.framework.TestCase and a method
> starting with "test", to invoke my WS method
> 3. Build my project, put the JAR file in the correct directory
> 4. Added a JUnit Request sampler in JMeter, my JUnit class and the test*
> method appear so I use them
> 5. Run JMeter
>
> but in the Result Tree listener, got such message:
>
> Thread Name: Thread Group 1-1
> Sample Start: 2012-12-17 17:17:58 IRST
> Load time: 0
> Latency: 0
> Size in bytes: 0
> Headers size in bytes: 0
> Body size in bytes: 0
> Sample Count: 1
> Error Count: 1
> Response code: 1000
> Response message:
>
> Response headers:
>
>
> SampleResult fields:
> ContentType:
> DataEncoding: windows-1252
>
> Any idea what is wrong?

Check the jmeter.log file for any relevant error messages.

Also check the console window (JMeter tries to capture all errors and
log them, but there may be some relevant output in the console).

> I will appreciate that.
>
> --
> Yours Faithfully,
> Masood Ghasemzadeh

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
For additional commands, e-mail: user-help@jmeter.apache.org


Mime
View raw message