jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sarah Pimentel <sarah.pimen...@gmail.com>
Subject Re: [JMeter - Configuration]
Date Sun, 04 Mar 2012 20:36:26 GMT
Are you sending all the required params?
I had some problems to log on my cas also, but then I downloaded an app to
get the http requests so I could see all data that was being posted. I
recorded the manual logon and found out that besides the username and
password there were some other parameters I was missing.
Have you tried something similar or is that not your case?

On Sun, Mar 4, 2012 at 5:31 PM, rahul.soa <rahul.soa@googlemail.com> wrote:

> I progressed on this little bit. Now I'm able to GET this (please see
> the 2nd point in the previous email thread)
>
>
> https://sso-intranet.companydomain.com/cas/login?service=http://companydomain.com/WebApplicationName
>
> I can see all html and javascript for login page in the response (in
> View Results Tree)
>
> my next request is POST and it seems POST (sending username and
> password) is not working. Always getting the resonse for same login
> page. (to provide username and password).
>
> Can anyone please help?
>
> Many thanks!
> Rahul
>
> On 3/4/12, rahul.soa <rahul.soa@googlemail.com> wrote:
> > Hello All,
> >
> > I'm new to Apache JMeter. I first downloaded this great product today and
> > tested with public websites and it worked like charm.
> >
> > Now its my web application's turn.
> > I am working on an enterprise web application. I just want to start with
> > testing one JSP page of my web application which takes lot of time to
> load
> > (/WebApplicationName/PageToTest.do).
> >
> >
> > Here is the quick flow of web application load: When user first time
> sends
> > request for web application, then it passes thru a Central Authorization
> > System(CAS) which requires valid username and password. Then user's
> request
> > goes to proxy HTTP server, which is forwarded to SunOne Application
> Server
> > (web container<->EJB container<->Database).
> >
> > When I try with different settings in Jmeter, it seems request is not
> > reaching to Application Server. I'm pretty much sure that this is
> > configuration issue as I don't know where to set proxy server/CAS
> > username/password.
> >
> > This is users do in web browser:
> > ========================
> >
> > 1. User send request
> >
> > http://companydomain.com/WebApplicationName
> >
> > 2. if user is not logged in then will be directed to
> >
> >
> https://sso-intranet.companydomain.com/cas/login?service=http://companydomain.com/WebApplicationName
> >
> > where user has to provide username/password
> >
> > 3. with valid username and password, it loads the web application
> >
> >
> > Can you please help me where to set the above settings and CAS
> > authentication credentials in Jmeter.
> >
> >
> > Many thanks in advance,
> >
> > Rahul
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
> For additional commands, e-mail: user-help@jmeter.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message