jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CHARLES BAKER <chba...@clemson.edu>
Subject Re: [JMeter - Configuration]
Date Mon, 05 Mar 2012 15:07:56 GMT
That blogspot URL doesn't resolve for me. Does it work for anyone else?
--
Charles H. Baker, Systems Programmer II CCIT/CSO
Don't see me in my cubicle? Try AIM: rascharles GTalk: chbaker@g.clemson.edu
chbaker@clemson.edu | o: 864.656.8069 | gv: 864.990.1297
Begin challenging your own assumptions. Your assumptions are your windows on
the world. Scrub them off every once in a while, or the light won't come in.
Alan Alda



On Mar 5, 2012, at 5:20 AM, Shaba K wrote:

> Hey there ...
> 
> have a look at this blog ...see if it helps you
> http://automationwithselenium.blospot.com
> 
> -Shabana
> 
> On Sun, Mar 4, 2012 at 10:25 PM, Robin D. Wilson <rwilson2@gmail.com> wrote:
> 
>> There are a couple of things to consider:
>> 
>> 1) Most authentication systems use cookies, so if your app does, you'll
>> need to add a "Cookie Manager" config element.
>> 
>> 2) Some apps require hidden values in the POST attributes, so you need to
>> make sure you include those too. It is usually best to add a "HTTP Proxy"
>> (under the non-config elements), and record an actual session from your
>> browser to make sure that you are setting up things the same way a browser
>> would.
>> 
>> --
>> Robin D. Wilson
>> 
>> 
>> 
>> On Mar 4, 2012, at 2:36 PM, Sarah Pimentel <sarah.pimentel@gmail.com>
>> wrote:
>> 
>>> Are you sending all the required params?
>>> I had some problems to log on my cas also, but then I downloaded an app
>> to
>>> get the http requests so I could see all data that was being posted. I
>>> recorded the manual logon and found out that besides the username and
>>> password there were some other parameters I was missing.
>>> Have you tried something similar or is that not your case?
>>> 
>>> On Sun, Mar 4, 2012 at 5:31 PM, rahul.soa <rahul.soa@googlemail.com>
>> wrote:
>>> 
>>>> I progressed on this little bit. Now I'm able to GET this (please see
>>>> the 2nd point in the previous email thread)
>>>> 
>>>> 
>>>> 
>> https://sso-intranet.companydomain.com/cas/login?service=http://companydomain.com/WebApplicationName
>>>> 
>>>> I can see all html and javascript for login page in the response (in
>>>> View Results Tree)
>>>> 
>>>> my next request is POST and it seems POST (sending username and
>>>> password) is not working. Always getting the resonse for same login
>>>> page. (to provide username and password).
>>>> 
>>>> Can anyone please help?
>>>> 
>>>> Many thanks!
>>>> Rahul
>>>> 
>>>> On 3/4/12, rahul.soa <rahul.soa@googlemail.com> wrote:
>>>>> Hello All,
>>>>> 
>>>>> I'm new to Apache JMeter. I first downloaded this great product today
>> and
>>>>> tested with public websites and it worked like charm.
>>>>> 
>>>>> Now its my web application's turn.
>>>>> I am working on an enterprise web application. I just want to start
>> with
>>>>> testing one JSP page of my web application which takes lot of time to
>>>> load
>>>>> (/WebApplicationName/PageToTest.do).
>>>>> 
>>>>> 
>>>>> Here is the quick flow of web application load: When user first time
>>>> sends
>>>>> request for web application, then it passes thru a Central
>> Authorization
>>>>> System(CAS) which requires valid username and password. Then user's
>>>> request
>>>>> goes to proxy HTTP server, which is forwarded to SunOne Application
>>>> Server
>>>>> (web container<->EJB container<->Database).
>>>>> 
>>>>> When I try with different settings in Jmeter, it seems request is not
>>>>> reaching to Application Server. I'm pretty much sure that this is
>>>>> configuration issue as I don't know where to set proxy server/CAS
>>>>> username/password.
>>>>> 
>>>>> This is users do in web browser:
>>>>> ========================
>>>>> 
>>>>> 1. User send request
>>>>> 
>>>>> http://companydomain.com/WebApplicationName
>>>>> 
>>>>> 2. if user is not logged in then will be directed to
>>>>> 
>>>>> 
>>>> 
>> https://sso-intranet.companydomain.com/cas/login?service=http://companydomain.com/WebApplicationName
>>>>> 
>>>>> where user has to provide username/password
>>>>> 
>>>>> 3. with valid username and password, it loads the web application
>>>>> 
>>>>> 
>>>>> Can you please help me where to set the above settings and CAS
>>>>> authentication credentials in Jmeter.
>>>>> 
>>>>> 
>>>>> Many thanks in advance,
>>>>> 
>>>>> Rahul
>>>>> 
>>>> 
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
>>>> For additional commands, e-mail: user-help@jmeter.apache.org
>>>> 
>>>> 
>> 
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
>> For additional commands, e-mail: user-help@jmeter.apache.org
>> 
>> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
For additional commands, e-mail: user-help@jmeter.apache.org


Mime
View raw message