jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Basim Baassiri <ba...@baassiri.ca>
Subject Re: looking for workaround for numberformatexception on response header
Date Tue, 03 Jan 2012 17:24:54 GMT
I have the same configuration with the exclusion of Proxy server
details.....

On Tue, Jan 3, 2012 at 12:01 PM, Shmuel Krakower <shmulikk@gmail.com> wrote:

> Hi,
> This is not related to the assertion.
>
> I had the same problem when using this on a web application behind a proxy
> server with
> HTTP Sampler using the HC4 and retrieve all embeded resources with
> concurrent threads +
> Cache manager set to use cache for GET requests +
> Default HTTP request set to a proxy.
>
> I think it worked for me when setting the proxy config on the HTTP Sampler
> itself instead of the defaults, but I'm not sure.
>
> Shmuel.
>
> On Tue, Jan 3, 2012 at 6:34 PM, Basim Baassiri <basim@baassiri.ca> wrote:
>
> > Hi
> > I'm using the http cache manager and my http sampler is set to retrieve
> all
> > embedded resources.  In addition, i have an assertion to check the
> response
> > code of 200
> >
> > This is what I'm seeing in the sample result tab in the view results tree
> >
> > Thread Name: Thread Group  1-6
> > Sample Start: 2012-01-03 11:30:45 EST
> > Load time: 105
> > Latency: 73
> > Size in bytes: 35158
> > Headers size in bytes: 302
> > Body size in bytes: 34856
> > Sample Count: 1
> > Error Count: 1
> > Response code: Non HTTP response code: java.lang.NumberFormatException
> > Response message: Non HTTP response message: For input string: "28800,
> > public"
> >
> > Response headers:
> > HTTP/1.1 200 OK
> > Date: Tue, 03 Jan 2012 16:30:23 GMT
> > Server: Apache/2.2.3 (Red Hat)
> > Accept-Ranges: bytes
> > Content-Length: 19669
> > Cache-Control: max-age=28800, public
> > Expires: Wed, 04 Jan 2012 00:22:58 GMT
> > Age: 445
> > Keep-Alive: timeout=15, max=97
> > Connection: Keep-Alive
> > Content-Type: image/png
> >
> >
> > HTTPSampleResult fields:
> > ContentType: image/png
> > DataEncoding: null
> >
> > Any suggestions other than removing the assertion?  My tests are
> reporting
> > in as failed
> >
> > Thanks in advance
> >
> > Basim
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message