jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Devaney <bdeva...@docfinity.com>
Subject Authorization problem
Date Wed, 30 Nov 2011 21:07:17 GMT
I am running into an issue with JMeter passing in authorization to web
service calls under some circumstances and not passing in the
authorization in others.

I have a number of JMeter scripts that I have been using for testing
software.  These have been working correctly for quite some time.  I can
run them in two modes: in the JMeter GUI and as part of another test
engine.  Both have been successful in the past, but recently, the test
script does not pass in the authorization in the web service calls.  

The JMeter scripts are identical in both modes except for enabling a
User Parameters node that contains settings for one run of the script in
the GUI.  If I use the test engine, all parameters are passed in and the
results saved to file.  Then the next test is run with new settings and
the results saved.

What is happening now is that running the script in the GUI will work
and running it with my test engine will fail with "HTTP Status 401 -
Full authentication is required to access this resource".

I ran the Charles Web Debugging Proxy and found that when the web
service calls worked, the Authorization line in the header was included,
but missing from the calls that were generated by the test engine and
failed.  

The JMeter script is using the same HTTP Authorization manager it always
has, as well as the same Cookie Manager using policy rfc2109.  


-- 

Brian Devaney
Software Developer
DocFinity®
(814) 238-0038x274
mailto:bdevaney@DocFinity.com
http://www.docfinity.com/
 


DISCLAIMER: This email may contain proprietary information, some or all
of which may be legally privileged. It is for the intended recipient
only. If an addressing or transmission error has misdirected this email,
please notify the author by replying to this email. If you are not the
intended recipient, you may not use, disclose, distribute, copy, print,
or rely on this email.


Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message