jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From chaitanya bhatt <bhatt.chaita...@gmail.com>
Subject Re: can't run jmeter on Ubuntu 10.04.1? error = java.lang.Throwable: Could not access /usr/share/jmeter/lib/junit at org.apache.jmeter.NewDriver.<clinit>(NewDriver.java:96)
Date Thu, 14 Oct 2010 03:51:56 GMT
I guess similar issue has already been resolved in a jmeter thread before.

Here is the link::
http://www.mail-archive.com/jmeter-user@jakarta.apache.org/msg29281.html

-Chaitanya M Bhatt
http://www.performancecompetence.com
On Thu, Oct 14, 2010 at 5:07 AM, Kurt Wiseman <kurt.wiseman@apparent.com>wrote:

> after typing "jmeter" at the command line I followed the instructions and
> did:
>
> sudo apt-get install jmeter
>
> Here''s the install output:
>
> > Reading package lists... Done
> > Building dependency tree
> > Reading state information... Done
> > The following extra packages will be installed:
> >   bsh default-jre fop icedtea-6-jre-cacao java-wrappers jmeter-help
> jmeter-http libaccess-bridge-java
> >   libaccess-bridge-java-jni libavalon-framework-java libbatik-java
> libbsf-java libcommons-codec-java
> >   libcommons-collections3-java libcommons-httpclient-java
> libcommons-io-java libcommons-jexl-java
> >   libcommons-lang-java libcommons-logging-java libexcalibur-logger-java
> libexcalibur-logkit-java libflac8
> >   libgeronimo-jms-1.1-spec-java libgnuinet-java libgnujaf-java
> libgnumail-java libhtmlparser-java
> >   libjaxp1.3-java libjcharts-java libjline-java libjtidy-java
> liblog4j1.2-java libogg0 liboro-java libpulse0
> >   libsaxon-java libservlet2.4-java libsndfile1 libvorbis0a libvorbisenc2
> libxalan2-java libxerces2-java
> >   libxml-commons-external-java libxmlgraphics-commons-java libxp6
> libxpp3-java libxstream-java libxtst6
> >   openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib rhino
> ttf-dejavu-extra
> > Suggested packages:
> >   bsh-doc bsh-gcj fop-doc libavalon-framework-java-doc jython
> libcommons-collections3-java-doc
> >   libcommons-httpclient-java-doc libcommons-io-java-doc
> libcommons-logging-java-doc libgnumail-java-doc
> >   libhtmlparser-java-doc libjaxp1.3-java-gcj libjline-java-doc
> libjtidy-java-doc ant liblog4j1.2-java-gcj
> >   libmx4j-java pulseaudio libjdom1-java libsaxon-java-doc
> libservlet2.4-java-gcj libxalan2-java-doc
> >   libxsltc-java libxalan2-java-gcj libxerces2-java-doc
> libxerces2-java-gcj libdom4j-java libjoda-time-java
> >   libstax-java libxom-java libcglib2.1-java libjettison-java
> icedtea6-plugin libnss-mdns sun-java6-fonts
> >   ttf-baekmuk ttf-unfonts ttf-unfonts-core ttf-sazanami-gothic
> ttf-kochi-gothic ttf-sazanami-mincho
> >   ttf-kochi-mincho ttf-wqy-microhei ttf-wqy-zenhei ttf-indic-fonts-core
> ttf-telugu-fonts ttf-oriya-fonts
> >   ttf-kannada-fonts ttf-bengali-fonts rhino-doc
> > The following NEW packages will be installed:
> >   bsh default-jre fop java-wrappers jmeter jmeter-help jmeter-http
> libaccess-bridge-java
> >   libaccess-bridge-java-jni libavalon-framework-java libbatik-java
> libbsf-java libcommons-codec-java
> >   libcommons-collections3-java libcommons-httpclient-java
> libcommons-io-java libcommons-jexl-java
> >   libcommons-lang-java libcommons-logging-java libexcalibur-logger-java
> libexcalibur-logkit-java libflac8
> >   libgeronimo-jms-1.1-spec-java libgnuinet-java libgnujaf-java
> libgnumail-java libhtmlparser-java
> >   libjaxp1.3-java libjcharts-java libjline-java libjtidy-java
> liblog4j1.2-java libogg0 liboro-java libpulse0
> >   libsaxon-java libservlet2.4-java libsndfile1 libvorbis0a libvorbisenc2
> libxalan2-java libxerces2-java
> >   libxml-commons-external-java libxmlgraphics-commons-java libxp6
> libxpp3-java libxstream-java libxtst6
> >   openjdk-6-jre rhino ttf-dejavu-extra
> > The following packages will be upgraded:
> >   icedtea-6-jre-cacao openjdk-6-jre-headless openjdk-6-jre-lib
> > 3 upgraded, 51 newly installed, 0 to remove and 41 not upgraded.
> > Need to get 60.7MB of archives.
> > After this operation, 51.7MB of additional disk space will be used.
> > Do you want to continue [Y/n]? y
> > Get:1 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main
> icedtea-6-jre-cacao 6b18-1.8.1-0ubuntu1 [375kB]
> > Get:2 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main
> openjdk-6-jre-lib 6b18-1.8.1-0ubuntu1 [5,907kB]
> > Get:3 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main
> openjdk-6-jre-headless 6b18-1.8.1-0ubuntu1 [25.5MB]
> > Get:4 http://us.archive.ubuntu.com/ubuntu/ lucid/main libjline-java
> 0.9.94-5 [68.2kB]
> > Get:5 http://us.archive.ubuntu.com/ubuntu/ lucid/main bsh
> 2.0b4-10ubuntu2 [271kB]
> > Get:6 http://us.archive.ubuntu.com/ubuntu/ lucid/main libogg0
> 1.1.4~dfsg-2 [17.3kB]
> > Get:7 http://us.archive.ubuntu.com/ubuntu/ lucid/main libflac8
> 1.2.1-2build2 [151kB]
> > Get:8 http://us.archive.ubuntu.com/ubuntu/ lucid/main libvorbis0a
> 1.2.3-3ubuntu1 [111kB]
> > Get:9 http://us.archive.ubuntu.com/ubuntu/ lucid/main libvorbisenc2
> 1.2.3-3ubuntu1 [97.2kB]
> > Get:10 http://us.archive.ubuntu.com/ubuntu/ lucid/main libsndfile1
> 1.0.21-2 [233kB]
> > Get:11 http://us.archive.ubuntu.com/ubuntu/ lucid/main libxtst6
> 2:1.1.0-2 [19.9kB]
> > Get:12 http://us.archive.ubuntu.com/ubuntu/ lucid/main libpulse0
> 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14 [274kB]
> > Get:13 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libaccess-bridge-java 1.26.2-3 [409kB]
> > Get:14 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libaccess-bridge-java-jni 1.26.2-3 [8,676B]
> > Get:15 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main
> openjdk-6-jre 6b18-1.8.1-0ubuntu1 [271kB]
> > Get:16 http://us.archive.ubuntu.com/ubuntu/ lucid/main default-jre
> 1.6-34 [1,068B]
> > Get:17 http://us.archive.ubuntu.com/ubuntu/ lucid/main libjaxp1.3-java
> 1.3.04-5ubuntu3 [348kB]
> > Get:18 http://us.archive.ubuntu.com/ubuntu/ lucid/main libxerces2-java
> 2.9.1-4ubuntu1 [1,113kB]
> > Get:19 http://us.archive.ubuntu.com/ubuntu/ lucid/main libxalan2-java
> 2.7.1-5ubuntu1 [3,354kB]
> > Get:20 http://us.archive.ubuntu.com/ubuntu/ lucid/main libbsf-java
> 1:2.4.0-3 [296kB]
> > Get:21 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libavalon-framework-java 4.2.0-7 [69.8kB]
> > Get:22 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libcommons-io-java 1.4-2ubuntu1 [102kB]
> > Get:23 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libcommons-logging-java 1.1.1-7 [116kB]
> > Get:24 http://us.archive.ubuntu.com/ubuntu/ lucid/universe java-wrappers
> 0.1.15 [8,508B]
> > Get:25 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
> libxml-commons-external-java 1.3.05-1 [103kB]
> > Get:26 http://us.archive.ubuntu.com/ubuntu/ lucid/universe libbatik-java
> 1.7.ubuntu-4ubuntu1 [5,823kB]
> > Get:27 http://us.archive.ubuntu.com/ubuntu/ lucid/main libxp6
> 1:1.0.0.xsf1-2build1 [18.2kB]
> > Get:28 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
> libxmlgraphics-commons-java 1.3.1.dfsg-4 [476kB]
> > Get:29 http://us.archive.ubuntu.com/ubuntu/ lucid/universe fop
> 1:0.95.dfsg-10 [2,086kB]
> > Get:30 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libcommons-collections3-java 3.2.1-4 [602kB]
> > Get:31 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libcommons-codec-java 1.4-2 [61.0kB]
> > Get:32 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libcommons-httpclient-java 3.1-9 [306kB]
> > Get:33 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
> libcommons-jexl-java 1.1-1 [121kB]
> > Get:34 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libcommons-lang-java 2.4-4 [249kB]
> > Get:35 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libgeronimo-jms-1.1-spec-java 1.1-0ubuntu2 [20.8kB]
> > Get:36 http://us.archive.ubuntu.com/ubuntu/ lucid/main libgnujaf-java
> 1.1.1-5 [62.6kB]
> > Get:37 http://us.archive.ubuntu.com/ubuntu/ lucid/main libgnuinet-java
> 1.1.1-4 [388kB]
> > Get:38 http://us.archive.ubuntu.com/ubuntu/ lucid/main libgnumail-java
> 1.1.2-4 [286kB]
> > Get:39 http://us.archive.ubuntu.com/ubuntu/ lucid/main liblog4j1.2-java
> 1.2.15-9ubuntu2 [344kB]
> > Get:40 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libexcalibur-logkit-java 2.0-2ubuntu2 [75.5kB]
> > Get:41 http://us.archive.ubuntu.com/ubuntu/ lucid/main
> libservlet2.4-java 5.0.30-10 [139kB]
> > Get:42 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
> libexcalibur-logger-java 2.1-2 [72.8kB]
> > Get:43 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
> libjcharts-java 0.7.5-1 [125kB]
> > Get:44 http://us.archive.ubuntu.com/ubuntu/ lucid/universe libjtidy-java
> 7+svn20070309-4 [238kB]
> > Get:45 http://us.archive.ubuntu.com/ubuntu/ lucid/main liboro-java
> 2.0.8a-7 [70.1kB]
> > Get:46 http://us.archive.ubuntu.com/ubuntu/ lucid/main libxpp3-java
> 1.1.4c-1 [348kB]
> > Get:47 http://us.archive.ubuntu.com/ubuntu/ lucid/main libxstream-java
> 1.3.1-6 [395kB]
> > Get:48 http://us.archive.ubuntu.com/ubuntu/ lucid/main rhino 1.7R2-3
> [730kB]
> > Get:49 http://us.archive.ubuntu.com/ubuntu/ lucid/universe jmeter
> 2.3.4-2ubuntu1 [1,535kB]
> > Get:50 http://us.archive.ubuntu.com/ubuntu/ lucid/universe jmeter-help
> 2.3.4-2ubuntu1 [2,589kB]
> > Get:51 http://us.archive.ubuntu.com/ubuntu/ lucid/universe
> libhtmlparser-java 1.6.20060610.dfsg0-3 [271kB]
> > Get:52 http://us.archive.ubuntu.com/ubuntu/ lucid/universe jmeter-http
> 2.3.4-2ubuntu1 [289kB]
> > Get:53 http://us.archive.ubuntu.com/ubuntu/ lucid/universe libsaxon-java
> 1:6.5.5-6 [577kB]
> > Get:54 http://us.archive.ubuntu.com/ubuntu/ lucid/main ttf-dejavu-extra
> 2.30-2 [3,107kB]
> > Fetched 60.7MB in 12s (4,878kB/s)
> > Extracting templates from packages: 100%
> > (Reading database ... 70956 files and directories currently installed.)
> > Preparing to replace icedtea-6-jre-cacao 6b18-1.8-4ubuntu3 (using
> .../icedtea-6-jre-cacao_6b18-1.8.1-0ubuntu1_amd64.deb) ...
> > Unpacking replacement icedtea-6-jre-cacao ...
> > Preparing to replace openjdk-6-jre-lib 6b18-1.8-4ubuntu3 (using
> .../openjdk-6-jre-lib_6b18-1.8.1-0ubuntu1_all.deb) ...
> > Unpacking replacement openjdk-6-jre-lib ...
> > Preparing to replace openjdk-6-jre-headless 6b18-1.8-4ubuntu3 (using
> .../openjdk-6-jre-headless_6b18-1.8.1-0ubuntu1_amd64.deb) ...
> > Unpacking replacement openjdk-6-jre-headless ...
> > Selecting previously deselected package libjline-java.
> > Unpacking libjline-java (from .../libjline-java_0.9.94-5_all.deb) ...
> > Selecting previously deselected package bsh.
> > Unpacking bsh (from .../bsh_2.0b4-10ubuntu2_all.deb) ...
> > Selecting previously deselected package libogg0.
> > Unpacking libogg0 (from .../libogg0_1.1.4~dfsg-2_amd64.deb) ...
> > Selecting previously deselected package libflac8.
> > Unpacking libflac8 (from .../libflac8_1.2.1-2build2_amd64.deb) ...
> > Selecting previously deselected package libvorbis0a.
> > Unpacking libvorbis0a (from .../libvorbis0a_1.2.3-3ubuntu1_amd64.deb) ...
> > Selecting previously deselected package libvorbisenc2.
> > Unpacking libvorbisenc2 (from .../libvorbisenc2_1.2.3-3ubuntu1_amd64.deb)
> ...
> > Selecting previously deselected package libsndfile1.
> > Unpacking libsndfile1 (from .../libsndfile1_1.0.21-2_amd64.deb) ...
> > Selecting previously deselected package libxtst6.
> > Unpacking libxtst6 (from .../libxtst6_2%3a1.1.0-2_amd64.deb) ...
> > Selecting previously deselected package libpulse0.
> > Unpacking libpulse0 (from
> .../libpulse0_1%3a0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14_amd64.deb)
> ...
> > Selecting previously deselected package libaccess-bridge-java.
> > Unpacking libaccess-bridge-java (from
> .../libaccess-bridge-java_1.26.2-3_all.deb) ...
> > Selecting previously deselected package libaccess-bridge-java-jni.
> > Unpacking libaccess-bridge-java-jni (from
> .../libaccess-bridge-java-jni_1.26.2-3_amd64.deb) ...
> > Selecting previously deselected package openjdk-6-jre.
> > Unpacking openjdk-6-jre (from
> .../openjdk-6-jre_6b18-1.8.1-0ubuntu1_amd64.deb) ...
> > Selecting previously deselected package default-jre.
> > Unpacking default-jre (from .../default-jre_1.6-34_amd64.deb) ...
> > Selecting previously deselected package libjaxp1.3-java.
> > Unpacking libjaxp1.3-java (from
> .../libjaxp1.3-java_1.3.04-5ubuntu3_amd64.deb) ...
> > Selecting previously deselected package libxerces2-java.
> > Unpacking libxerces2-java (from
> .../libxerces2-java_2.9.1-4ubuntu1_all.deb) ...
> > Selecting previously deselected package libxalan2-java.
> > Unpacking libxalan2-java (from
> .../libxalan2-java_2.7.1-5ubuntu1_amd64.deb) ...
> > Selecting previously deselected package libbsf-java.
> > Unpacking libbsf-java (from .../libbsf-java_1%3a2.4.0-3_all.deb) ...
> > Selecting previously deselected package libavalon-framework-java.
> > Unpacking libavalon-framework-java (from
> .../libavalon-framework-java_4.2.0-7_all.deb) ...
> > Selecting previously deselected package libcommons-io-java.
> > Unpacking libcommons-io-java (from
> .../libcommons-io-java_1.4-2ubuntu1_all.deb) ...
> > Selecting previously deselected package libcommons-logging-java.
> > Unpacking libcommons-logging-java (from
> .../libcommons-logging-java_1.1.1-7_all.deb) ...
> > Selecting previously deselected package java-wrappers.
> > Unpacking java-wrappers (from .../java-wrappers_0.1.15_all.deb) ...
> > Selecting previously deselected package libxml-commons-external-java.
> > Unpacking libxml-commons-external-java (from
> .../libxml-commons-external-java_1.3.05-1_all.deb) ...
> > Selecting previously deselected package libbatik-java.
> > Unpacking libbatik-java (from
> .../libbatik-java_1.7.ubuntu-4ubuntu1_all.deb) ...
> > Selecting previously deselected package libxp6.
> > Unpacking libxp6 (from .../libxp6_1%3a1.0.0.xsf1-2build1_amd64.deb) ...
> > Selecting previously deselected package libxmlgraphics-commons-java.
> > Unpacking libxmlgraphics-commons-java (from
> .../libxmlgraphics-commons-java_1.3.1.dfsg-4_all.deb) ...
> > Selecting previously deselected package fop.
> > Unpacking fop (from .../fop_1%3a0.95.dfsg-10_all.deb) ...
> > Selecting previously deselected package libcommons-collections3-java.
> > Unpacking libcommons-collections3-java (from
> .../libcommons-collections3-java_3.2.1-4_all.deb) ...
> > Selecting previously deselected package libcommons-codec-java.
> > Unpacking libcommons-codec-java (from
> .../libcommons-codec-java_1.4-2_all.deb) ...
> > Selecting previously deselected package libcommons-httpclient-java.
> > Unpacking libcommons-httpclient-java (from
> .../libcommons-httpclient-java_3.1-9_all.deb) ...
> > Selecting previously deselected package libcommons-jexl-java.
> > Unpacking libcommons-jexl-java (from
> .../libcommons-jexl-java_1.1-1_all.deb) ...
> > Selecting previously deselected package libcommons-lang-java.
> > Unpacking libcommons-lang-java (from
> .../libcommons-lang-java_2.4-4_all.deb) ...
> > Selecting previously deselected package libgeronimo-jms-1.1-spec-java.
> > Unpacking libgeronimo-jms-1.1-spec-java (from
> .../libgeronimo-jms-1.1-spec-java_1.1-0ubuntu2_all.deb) ...
> > Selecting previously deselected package libgnujaf-java.
> > Unpacking libgnujaf-java (from .../libgnujaf-java_1.1.1-5_all.deb) ...
> > Selecting previously deselected package libgnuinet-java.
> > Unpacking libgnuinet-java (from .../libgnuinet-java_1.1.1-4_all.deb) ...
> > Selecting previously deselected package libgnumail-java.
> > Unpacking libgnumail-java (from .../libgnumail-java_1.1.2-4_all.deb) ...
> > Selecting previously deselected package liblog4j1.2-java.
> > Unpacking liblog4j1.2-java (from
> .../liblog4j1.2-java_1.2.15-9ubuntu2_amd64.deb) ...
> > Selecting previously deselected package libexcalibur-logkit-java.
> > Unpacking libexcalibur-logkit-java (from
> .../libexcalibur-logkit-java_2.0-2ubuntu2_all.deb) ...
> > Selecting previously deselected package libservlet2.4-java.
> > Unpacking libservlet2.4-java (from
> .../libservlet2.4-java_5.0.30-10_all.deb) ...
> > Selecting previously deselected package libexcalibur-logger-java.
> > Unpacking libexcalibur-logger-java (from
> .../libexcalibur-logger-java_2.1-2_all.deb) ...
> > Selecting previously deselected package libjcharts-java.
> > Unpacking libjcharts-java (from .../libjcharts-java_0.7.5-1_all.deb) ...
> > Selecting previously deselected package libjtidy-java.
> > Unpacking libjtidy-java (from .../libjtidy-java_7+svn20070309-4_all.deb)
> ...
> > Selecting previously deselected package liboro-java.
> > Unpacking liboro-java (from .../liboro-java_2.0.8a-7_all.deb) ...
> > Selecting previously deselected package libxpp3-java.
> > Unpacking libxpp3-java (from .../libxpp3-java_1.1.4c-1_all.deb) ...
> > Selecting previously deselected package libxstream-java.
> > Unpacking libxstream-java (from .../libxstream-java_1.3.1-6_all.deb) ...
> > Selecting previously deselected package rhino.
> > Unpacking rhino (from .../archives/rhino_1.7R2-3_all.deb) ...
> > Selecting previously deselected package jmeter.
> > Unpacking jmeter (from .../jmeter_2.3.4-2ubuntu1_all.deb) ...
> > Selecting previously deselected package jmeter-help.
> > Unpacking jmeter-help (from .../jmeter-help_2.3.4-2ubuntu1_all.deb) ...
> > Selecting previously deselected package libhtmlparser-java.
> > Unpacking libhtmlparser-java (from
> .../libhtmlparser-java_1.6.20060610.dfsg0-3_all.deb) ...
> > Selecting previously deselected package jmeter-http.
> > Unpacking jmeter-http (from .../jmeter-http_2.3.4-2ubuntu1_all.deb) ...
> > Selecting previously deselected package libsaxon-java.
> > Unpacking libsaxon-java (from .../libsaxon-java_1%3a6.5.5-6_all.deb) ...
> > Selecting previously deselected package ttf-dejavu-extra.
> > Unpacking ttf-dejavu-extra (from .../ttf-dejavu-extra_2.30-2_all.deb) ...
> > Processing triggers for man-db ...
> > Processing triggers for hicolor-icon-theme ...
> > Processing triggers for fontconfig ...
> > Setting up libjline-java (0.9.94-5) ...
> > Setting up bsh (2.0b4-10ubuntu2) ...
> >
> > Setting up libogg0 (1.1.4~dfsg-2) ...
> >
> > Setting up libflac8 (1.2.1-2build2) ...
> >
> > Setting up libvorbis0a (1.2.3-3ubuntu1) ...
> >
> > Setting up libvorbisenc2 (1.2.3-3ubuntu1) ...
> >
> > Setting up libsndfile1 (1.0.21-2) ...
> >
> > Setting up libxtst6 (2:1.1.0-2) ...
> >
> > Setting up libpulse0 (1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14)
> ...
> >
> > Setting up libjaxp1.3-java (1.3.04-5ubuntu3) ...
> > Setting up libxerces2-java (2.9.1-4ubuntu1) ...
> > Setting up libxalan2-java (2.7.1-5ubuntu1) ...
> > Setting up libbsf-java (1:2.4.0-3) ...
> > Setting up libavalon-framework-java (4.2.0-7) ...
> > Setting up libcommons-io-java (1.4-2ubuntu1) ...
> > Setting up libcommons-logging-java (1.1.1-7) ...
> > Setting up java-wrappers (0.1.15) ...
> > Setting up libxml-commons-external-java (1.3.05-1) ...
> > Setting up libxp6 (1:1.0.0.xsf1-2build1) ...
> >
> > Setting up libxmlgraphics-commons-java (1.3.1.dfsg-4) ...
> > Setting up libcommons-collections3-java (3.2.1-4) ...
> > Setting up libcommons-codec-java (1.4-2) ...
> > Setting up libcommons-httpclient-java (3.1-9) ...
> > Setting up libcommons-lang-java (2.4-4) ...
> > Setting up libgeronimo-jms-1.1-spec-java (1.1-0ubuntu2) ...
> > Setting up libgnujaf-java (1.1.1-5) ...
> > Setting up libgnuinet-java (1.1.1-4) ...
> > Setting up libgnumail-java (1.1.2-4) ...
> > Setting up liblog4j1.2-java (1.2.15-9ubuntu2) ...
> > Setting up libexcalibur-logkit-java (2.0-2ubuntu2) ...
> > Setting up libservlet2.4-java (5.0.30-10) ...
> > Setting up libexcalibur-logger-java (2.1-2) ...
> > Setting up libjtidy-java (7+svn20070309-4) ...
> > Setting up liboro-java (2.0.8a-7) ...
> > Setting up libxpp3-java (1.1.4c-1) ...
> > Setting up libxstream-java (1.3.1-6) ...
> > Setting up rhino (1.7R2-3) ...
> > update-alternatives: using /usr/bin/rhino to provide /usr/bin/js (js) in
> auto mode.
> >
> > Setting up jmeter-help (2.3.4-2ubuntu1) ...
> > Setting up ttf-dejavu-extra (2.30-2) ...
> > Setting up openjdk-6-jre-lib (6b18-1.8.1-0ubuntu1) ...
> > Setting up openjdk-6-jre-headless (6b18-1.8.1-0ubuntu1) ...
> >
> > Setting up icedtea-6-jre-cacao (6b18-1.8.1-0ubuntu1) ...
> > Setting up default-jre (1.6-34) ...
> > Setting up libaccess-bridge-java (1.26.2-3) ...
> > Setting up libbatik-java (1.7.ubuntu-4ubuntu1) ...
> > Setting up fop (1:0.95.dfsg-10) ...
> > Setting up libcommons-jexl-java (1.1-1) ...
> > Setting up libhtmlparser-java (1.6.20060610.dfsg0-3) ...
> > Setting up libsaxon-java (1:6.5.5-6) ...
> > Setting up libaccess-bridge-java-jni (1.26.2-3) ...
> >
> > Setting up openjdk-6-jre (6b18-1.8.1-0ubuntu1) ...
> > update-alternatives: using /usr/lib/jvm/java-6-openjdk/jre/bin/javaws to
> provide /usr/bin/javaws (javaws) in auto mode.
> > update-alternatives: using
> /usr/lib/jvm/java-6-openjdk/jre/bin/pluginappletviewer to provide
> /usr/bin/pluginappletviewer (pluginappletviewer) in auto mode.
> > update-alternatives: using /usr/lib/jvm/java-6-openjdk/jre/bin/policytool
> to provide /usr/bin/policytool (policytool) in auto mode.
> >
> > Setting up libjcharts-java (0.7.5-1) ...
> > Setting up jmeter (2.3.4-2ubuntu1) ...
> > Setting up jmeter-http (2.3.4-2ubuntu1) ...
> > Processing triggers for libc-bin ...
> > ldconfig deferred processing now taking place
>
>
>
> and here's what I get now:
>
> >  jmeter
> > [warning] /usr/bin/jmeter: Unable to locate commons-net in
> /usr/share/java
> > [warning] /usr/bin/jmeter: Unable to locate jboss-j2ee in /usr/share/java
> > [warning] /usr/bin/jmeter: Unable to locate jdom1 in /usr/share/java
> > [warning] /usr/bin/jmeter: Unable to locate junit in /usr/share/java
> > [warning] /usr/bin/jmeter: No JAVA_CMD set for run_java, falling back to
> JAVA_CMD = java
> > java.lang.Throwable: Could not access /usr/share/jmeter/lib/junit
> >       at org.apache.jmeter.NewDriver.<clinit>(NewDriver.java:96)
> > log_file=jmeter.log java.io.FileNotFoundException: jmeter.log (Permission
> denied)
> > [log_file-> System.out]
> > 2010/10/13 15:51:42 INFO  - jmeter.util.JMeterUtils: Setting Locale to
> en_US
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: Copyright (c) 1998-2009 The
> Apache Software Foundation
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: Version 2.3.4
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: java.version=1.6.0_18
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: java.vm.name=OpenJDK 64-Bit
> Server VM
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: os.name=Linux
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: os.arch=amd64
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: os.version=2.6.32-24-server
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: file.encoding=UTF-8
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: Default Locale=English (United
> States)
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: JMeter  Locale=English (United
> States)
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: JMeterHome=/usr/share/jmeter
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: user.dir  =/var/log/tomcat6
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: PWD       =/var/log/tomcat6
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: IP: 127.0.1.1 Name:
> XET-Tomcat-Local2 FullName: XET-Tomcat-Local2
> > 2010/10/13 15:51:42 INFO  - jmeter.JMeter: Loaded icon properties from
> org/apache/jmeter/images/icon.properties
> > 2010/10/13 15:51:43 WARN  - jmeter.gui.action.ActionRouter:
> java.awt.HeadlessException:
> > No X11 DISPLAY variable was set, but this program performed an operation
> which requires it.
> > 2010/10/13 15:51:43 FATAL - jmeter.JMeter: An error occurred:
>  java.awt.HeadlessException:
> > No X11 DISPLAY variable was set, but this program performed an operation
> which requires it.
> >       at
> java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:173)
> >       at java.awt.Window.<init>(Window.java:437)
> >       at java.awt.Frame.<init>(Frame.java:419)
> >       at java.awt.Frame.<init>(Frame.java:384)
> >       at javax.swing.JFrame.<init>(JFrame.java:174)
> >       at org.apache.jmeter.gui.MainFrame.<init>(MainFrame.java:131)
> >       at org.apache.jmeter.JMeter.startGui(JMeter.java:223)
> >       at org.apache.jmeter.JMeter.start(JMeter.java:343)
> >       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >       at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> >       at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> >       at java.lang.reflect.Method.invoke(Method.java:616)
> >       at org.apache.jmeter.NewDriver.main(NewDriver.java:207)
> >
> > An error occurred:
> > No X11 DISPLAY variable was set, but this program performed an operation
> which requires it.
>
>
>
> If I try sudo jmeter I get:
>
> > sudo jmeter
> > [warning] /usr/bin/jmeter: Unable to locate commons-net in
> /usr/share/java
> > [warning] /usr/bin/jmeter: Unable to locate jboss-j2ee in /usr/share/java
> > [warning] /usr/bin/jmeter: Unable to locate jdom1 in /usr/share/java
> > [warning] /usr/bin/jmeter: Unable to locate junit in /usr/share/java
> > [warning] /usr/bin/jmeter: No JAVA_CMD set for run_java, falling back to
> JAVA_CMD = java
> > java.lang.Throwable: Could not access /usr/share/jmeter/lib/junit
> >       at org.apache.jmeter.NewDriver.<clinit>(NewDriver.java:96)
> > An error occurred:
> > No X11 DISPLAY variable was set, but this program performed an operation
> which requires it.
>
> Finally, trying for nodisplay I get:
>
> > sudo jmeter -n
> > [sudo] password for kwiseman:
> > [warning] /usr/bin/jmeter: Unable to locate commons-net in
> /usr/share/java
> > [warning] /usr/bin/jmeter: Unable to locate jboss-j2ee in /usr/share/java
> > [warning] /usr/bin/jmeter: Unable to locate jdom1 in /usr/share/java
> > [warning] /usr/bin/jmeter: Unable to locate junit in /usr/share/java
> > [warning] /usr/bin/jmeter: No JAVA_CMD set for run_java, falling back to
> JAVA_CMD = java
> > java.lang.Throwable: Could not access /usr/share/jmeter/lib/junit
> >       at org.apache.jmeter.NewDriver.<clinit>(NewDriver.java:96)
> > Non-GUI runs require a test plan
>
>
>
> Any help would be greatly appreciated.
>
> Thanks,
> Kurt
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message