jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: FW: Recording problem
Date Tue, 05 Oct 2010 19:49:18 GMT
On 5 October 2010 17:36, radhika reddy <radhikareddy999@gmail.com> wrote:
> Hi I have used both firefox and IE and could find the same problem. When I
> tried with firefox it complained saying that "Untrusted certificate" and i
> was unable to add the certificate.

That is the way the proxy certificate works.
It is used to intercept the SSL traffic (in order to record it), so
you would not want the certificate to be automatically trusted.

But it should be possible to allow the certificate temporarily whilst
using the proxy recorder.
[Or indeed permanently - but that is not recommended because the
certificate is not secret]

If you cannot permit the certificate to be used by the browser, then
that is the browser's problem, not JMeter's.

Perhaps try a different browser. Opera works for me.

>
> On Tue, Oct 5, 2010 at 5:36 PM, Felix Frank <ff@mpexnet.de> wrote:
>
>> If you are still having certificate issues, you may need to resolve
>> those first.
>>
>> Basically, for each domain that receives requests during recording, your
>> browser needs a security exception. That's because Jmeter presents its
>> own certificate to the browser while running the proxy.
>>
>> Once you are certain that the certificates are not a problem, you will
>> need to find out where that error is coming from. I suspect that your
>> browser is telling you about a problem but will not elaborate further.
>>
>> Watch your web server log during a working log-on (no Jmeter recording
>> being done) and during the error. Note whether some requests is missing
>> during the latter.
>>
>> What browser are you using? Is it feasible to try a different one?
>>
>> HTH,
>> Felix
>>
>> On 10/05/2010 01:59 PM, Singireddy, Radhika wrote:
>> > When I hit the application url manually its displaying that "There is a
>> problem with this websites security certificate". Same is the case when I
>> tried recording with Jmeter.
>> > But When I enter the credentials username and password in the popup it is
>> directing to a page "The page cannot be displayed". There is no network
>> error or http error code displayed as such.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
>> For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>>
>>
>
>
> --
> Your friend.........Radhika!
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message