jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Frank ...@mpexnet.de>
Subject Re: Posting problem
Date Tue, 13 Jul 2010 12:32:48 GMT
Sounds strange. If all of your threads try to log in with the same
credentials and change those same credentials to something else, all but
the first running thread use the old credentials, so they are bound to
fail, no? (This is the the simultaneous scenario.)

Each of your threads needs its own pair of old/new credentials I think.

HTH
Felix

On 07/13/2010 02:26 PM, jriv wrote:
> 
> Yes, I have a cookie manager within the scope of the threads. I am using the
> https protocol, I'm not sure if that makes a difference. I'll explain the
> process I'm going through a little more clearly:
> 1. GET post update login form
> 2. POST updated login username (with "Follow Redirects" checked, the login
> screen should be the last redirected page)
> 3. POST login information with new username
> 4-6. Repeat steps 1-3 to change the username back to that in the csv.
> 
> For some reason only the first thread follows this correctly, subsequent
> threads fail at posting the new username, although they still post since
> every other step is successful.
> 
> I've been doing this with 3 users simultaneously, and it just occurred to me
> to try them consecutively instead to make sure if the problem was in my test
> or in the way the website handles this process. It seems that it's the
> website since my test just ran without any errors, so this may not be as
> much of a problem as I thought it was before. 

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message