jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From monpru <pr...@stud.ntnu.no>
Subject negative response times again
Date Thu, 08 Jul 2010 11:43:29 GMT

Hi,
I got negative latency values in my last load test of a web service. I
searched the web and found that this might have something to do with the jdk
I use? I wonder what the problem is or how to ensure that I get correct
latency in future tests? I am not allowed to use Wireshark or similar to
check transmission times. The load during the tests was quite low (350
requests/minute) and none of the machines involved in the test struggled. I
used 2 thread groups with one Constant Throughput Timer each, all samplers
are SOAP/XML-RPC Requests. I use csv format for logging.
I tried to re-run the test using different jdks and got results that
differed, but had negative and 0 latency in each of the tests.
I used JMeter 2.3.4 r785646
and tried with the following
-Java HotSpot(TM) Server VM (build 1.5.0_16-b02, mixed mode)
-BEA JRockit(R) (build
R26.4.0-63_CR302700-72606-1.5.0_06-20061127-1104-linux-ia32
-Java HotSpot(TM) Server VM (build 1.5.0_06-b05, mixed mode)
on a machine with CentOS release 4.7 and got negative and 0 latency for all.

I tried on a different machine using BEA WebLogic JRockit(TM) 1.4.2_08 JVM
R24.5.0-61 on Red Hat Enterprise Linux ES release 4 (Nahant Update 2): here
I only had 0 load time (the last value) for some requests, but no negative
or 0 latency. But I am unsure if this means the latency is correct this
time?

I might be overlooking something obvious here, so I would be thankful for
hints regarding this problem.

Regards,
Monique
-- 
View this message in context: http://jmeter.512774.n5.nabble.com/negative-response-times-again-tp1044999p1044999.html
Sent from the JMeter - User mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message