jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anamika aaa <anamika...@gmail.com>
Subject Re: Jmeter Cookie problem
Date Tue, 08 Jun 2010 07:35:30 GMT
I did it. but problem is i need to know hpw to extract the hidden files.

On Tue, Jun 8, 2010 at 12:41 PM, Ragini Thakur <raginit@cybage.com> wrote:

> Use Badboy to record the scripts and then import them to JMeter
>
> Regards,
> Ragini Thakur
>
> -----Original Message-----
> From: Anamika aaa [mailto:anamikaqtp@gmail.com]
> Sent: Tuesday, June 08, 2010 12:35 PM
> To: JMeter Users List
> Subject: Re: Jmeter Cookie problem
>
> Hi,
>
> Please tell me how to compare the browser witht JMETER ..
>
> How to extract the hidden files , i dont know how to find the hidden
> files..
>
>
> regards
>
> anamika
>
>
>
>
>
>
>
>
>
>
>
>
>
> On Tue, May 4, 2010 at 2:14 AM, Deepak Shetty <shettyd@gmail.com> wrote:
>
> > Please compare your browser to your jmeter.
> >
> >
> >
> > On Sat, May 1, 2010 at 11:51 PM, Anamika aaa <anamikaqtp@gmail.com>
> wrote:
> >
> > > Hi
> > >
> > >    I have recorded the script after changing to https..
> > >
> > > Regards
> > >
> > > On Fri, Apr 30, 2010 at 10:03 PM, Deepak Shetty <shettyd@gmail.com>
> > wrote:
> > >
> > > > >But stil its thowing the same error.
> > > > You must compare what the browser sends with what you are sending.
> In
> > the
> > > > case oif dynamic values , you must check previous responses and
> see
> > that
> > > > the
> > > > values you post on the next response match these.
> > > > If your application changed to https , did you rerecord your
> script?
> > > (e.g.
> > > > if the saml consumer mandates https , posting to it in http fails)
> > > > regards
> > > > deepak
> > > >
> > > >
> > > > On Fri, Apr 30, 2010 at 2:23 AM, Anamika aaa
> <anamikaqtp@gmail.com>
> > > wrote:
> > > >
> > > > > Hi
> > > > >
> > > > >  Thanks for ur suggestion. I tried extracting the variables
> using
> > > regular
> > > > > expressions though the variables and values are shown in the
> badboy
> > > > > recorded
> > > > > script. But stil its thowing the same error.
> > > > >
> > > > >  Regarding the java script i had run jmeter on the same
> application
> > in
> > > > http
> > > > > mode and it showed all the resulting pages and the files in
> it.But
> > this
> > > > > problem is coming after the application changed to https.
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > On Tue, Apr 27, 2010 at 10:14 PM, Deepak Shetty
> <shettyd@gmail.com>
> > > > wrote:
> > > > >
> > > > > > 1) JMeter does not support or execute javascript. However this
> is
> > not
> > > > > > necessarily a problem because some applications do display a
> > noscript
> > > > > > message (which is perhaps what you are seeing) and autosubmit
> the
> > > form
> > > > > with
> > > > > > javascript(which you will do as a separate request in JMeter)
> > > > > > 2) SAML parameter values are dynamic. If you have recorded and
> you
> > > > replay
> > > > > > the script it wont work. You must extract all the hidden
> values
> > from
> > > > the
> > > > > > request (Assuming you use a POST profile.)
> > > > > >
> > > > > >
> > > > > >
> > > > > > On Mon, Apr 26, 2010 at 11:50 PM, Anamika aaa <
> > anamikaqtp@gmail.com>
> > > > > > wrote:
> > > > > >
> > > > > > > Hi
> > > > > > >
> > > > > > > Thank u sebb for ur reply
> > > > > > > I tried using Follow redirects but now i am facing a new
> prob
> > along
> > > > > with
> > > > > > > the
> > > > > > > old one that says
> > > > > > >
> > > > > > >  1)Browser does not support JavaScript press continue to
> proceed
> > in
> > > > the
> > > > > > > ViewTree Listener. I have enabled Javascript in both IE
and
> > Mozilla
> > > > but
> > > > > > its
> > > > > > > still throwing the same error
> > > > > > >
> > > > > > > 2) The page that is throwing 401 unauthorised error also
> says
> > SAML
> > > > > > message
> > > > > > > is not getting validated . It s a Single Sign On Page.The
> Cookie
> > is
> > > > now
> > > > > > > getting set for the this page after the Follow Redirects
s
> > used.But
> > > > the
> > > > > > > error s still the same
> > > > > > >   Can anyone pleasetell me what the prob might be...
> > > > > > >
> > > > > > > Regards
> > > > > > >
> > > > > > >
> > > > > > > On Mon, Apr 26, 2010 at 5:04 PM, sebb <sebbaz@gmail.com>
> wrote:
> > > > > > >
> > > > > > > > On 26/04/2010, Anamika aaa <anamikaqtp@gmail.com>
wrote:
> > > > > > > > > Thanks for all the replies ..
> > > > > > > > >   i am using 2.3.2 now but its the same problem..
> > > > > > > >
> > > > > > > > The current version of JMeter is 2.3.4.
> > > > > > > >
> > > > > > > > >  The follow redirects is
> > > > > > > > >  already selected since it is a bad boy script
... But
> the
> > > > problem
> > > > > if
> > > > > > i
> > > > > > > > dont
> > > > > > > > >  tick the Automatically redirect checkbox my
application
> > throws
> > > a
> > > > > 302
> > > > > > > > >  response code and doesnt go further .
> > > > > > > >
> > > > > > > > So long as you tick "follow redirects" JMeter should
> follow
> > 302s.
> > > > > > > >
> > > > > > > > If it does not, please check the jmeter.log file for
> errors,
> > and
> > > > > check
> > > > > > > > the format of the 302 response in the Tree View Listener.
> > > > > > > >
> > > > > > > > >     After giving the credentials for login the
> application
> > > though
> > > > > > logs
> > > > > > > in
> > > > > > > > >  successfully it is going back to the same login
page
> instead
> > > of
> > > > > > > > redirecting
> > > > > > > > >  to the application..
> > > > > > > >
> > > > > > > > Some applications provide cookies as part of the redirect
> > > > processing.
> > > > > > > > These will not be seen by JMeter if you select
> "Automatically
> > > > > > > > redirect".
> > > > > > > >
> > > > > > > > >  Please let know if anyone has faced the same
type of
> > > > > > > > >  problem..
> > > > > > > >
> > > > > > > > Have you tried searching the mailing list for similar
> problems?
> > > > > > > >
> > > > > > > > >
> > > > > > > > >  Regards
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >  On Thu, Apr 22, 2010 at 10:51 PM, Deepak Shetty
<
> > > > > shettyd@gmail.com>
> > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > >  > Ensure you have follow redirects instead
of redirect
> > > > > > automatically.
> > > > > > > > Using
> > > > > > > > >  > View Results tree check whether the cookie
gets set
> and
> > > > whether
> > > > > > > JMeter
> > > > > > > > is
> > > > > > > > >  > passing it back
> > > > > > > > >  >
> > > > > > > > >  > On Wed, Apr 21, 2010 at 11:46 PM, Anamika
aaa <
> > > > > > anamikaqtp@gmail.com
> > > > > > > >
> > > > > > > > >  > wrote:
> > > > > > > > >  >
> > > > > > > > >  > > Hi ,
> > > > > > > > >  > >
> > > > > > > > >  > > I am trying to test a web application
using HTTPS
> on
> > > JMeter.
> > > > I
> > > > > > am
> > > > > > > > using
> > > > > > > > >  > > JMeter 2-2.  My test consists of the
following: Get
> the
> > > > login
> > > > > > > page,
> > > > > > > > post
> > > > > > > > >  > > login form parameters, get the enter
page. I have
> > recorded
> > > > the
> > > > > > > > script
> > > > > > > > >  > using
> > > > > > > > >  > > Badboy by giving all the login details.
> > > > > > > > >  > >
> > > > > > > > >  > > When I switch to HTTPS on 443, I am
redirected to
> the
> > > login
> > > > > page
> > > > > > > on
> > > > > > > > the
> > > > > > > > >  > > second and third requests. I do not
see the cookie
> > > > information
> > > > > > in
> > > > > > > > the
> > > > > > > > >  > > request tab in the results tree and
i am getting
> HTTP
> > > > > > > authorisation
> > > > > > > > >  > message
> > > > > > > > >  > > not validated error  I believe that
the Cookie
> Manager
> > is
> > > > not
> > > > > > > > passing the
> > > > > > > > >  > > cookie information back with each
subsequent
> request.
> > > > > > > > >  > > I have looked through the Users Guide,
FAQ, and Bug
> list
> > > for
> > > > > any
> > > > > > > > >  > > information
> > > > > > > > >  > > about the Cookie Manager handling
HTTPS request but
> have
> > > not
> > > > > > found
> > > > > > > > >  > > anything.
> > > > > > > > >  > > Has anyone experienced this behavior
using HTTPS in
> > > JMeter?
> > > > > > > > >  > >
> > > > > > > > >  > >
> > > > > > > > >  > > Regards
> > > > > > > > >  > >
> > > > > > > > >  >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > >
> ---------------------------------------------------------------------
> > > > > > > > To unsubscribe, e-mail:
> > > jmeter-user-unsubscribe@jakarta.apache.org
> > > > > > > > For additional commands, e-mail:
> > > > jmeter-user-help@jakarta.apache.org
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>
> "Legal Disclaimer: This electronic message and all contents contain
> information from Cybage Software Private Limited which may be privileged,
> confidential, or otherwise protected from disclosure. The information is
> intended to be for the addressee(s) only. If you are not an addressee, any
> disclosure, copy, distribution, or use of the contents of this message is
> strictly prohibited. If you have received this electronic message in error
> please notify the sender by reply e-mail to and destroy the original message
> and all copies. Cybage has taken every reasonable precaution to minimize the
> risk of malicious content in the mail, but is not liable for any damage you
> may sustain as a result of any malicious content in this e-mail. You should
> carry out your own malicious content checks before opening the e-mail or
> attachment."
> www.cybage.com
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message