jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Remote server connects but does not execute tests
Date Fri, 21 May 2010 08:26:14 GMT
Good point, but the number of threads is only updated in the local
GUI, and does not get updated by remote servers.

On 21/05/2010, Adrian Speteanu <asp.adieu@gmail.com> wrote:
> also a good question is: does the number of threads remain 0? (if this is
>  the case, it is usually a test plan configuration issue - for example you
>  use a schedule that is in the past, or you used variables for thread
>  configuration and one of them is not set, or 0...)
>
>
>  On Fri, May 21, 2010 at 2:27 AM, sebb <sebbaz@gmail.com> wrote:
>
>  > Does the test plan run OK locally on the client?
>  >
>  > Does it run OK locally on the server? (copy it manually)
>  >
>  > Have you ensured that any necessary data files are present on the server?
>  > (The above test should help here)
>  >
>  > Are you running identical versions of JMeter on client and server(s)?
>  > This is essential.
>  >
>  > Are you running identical versions of Java?
>  > Different Java versions may work, but they can cause problems with
>  > RMI, so try to ensure that at least they are the same versions (e.g.
>  > 1.5 or 1.6) even if they are not the same revision.
>  >
>  > On 18/05/2010, Lennon Pulda <lennon.p@gmail.com> wrote:
>  > > Hi,
>  > >
>  > >  I'm running into a problem while running remote tests on a particular 2
>  > >  machine setup currently. Machine 1/server ; machine 2/client.
>  > >
>  > >  When I remote-start the server from the GUI client, nothing happens in
>  > the
>  > >  gui, on the server, I only see the lines:
>  > >
>  > >  Starting the test on host 10.48.43.160:11001 @ Tue May 18 13:39:36 PDT
>  > 2010
>  > >  (1274215176090)
>  > >  Finished the test on host 10.48.43.160:11001 @ Tue May 18 13:39:36 PDT
>  > 2010
>  > >  (1274215176890)
>  > >
>  > >  (immediately) ...the tests do not run. So the machines connect, but the
>  > >  tests don't execute. I've seen this problem posted a few times in the
>  > >  archives but no clear solution that seems applicable to my setup as far
>  > as I
>  > >  can see. Both machines are ubuntu 9.10 linux. Connected on the same
>  > >  subnet. Tried using a specific port, same result. Verbose logs look
>  > like:
>  > >
>  > >  ...
>  > >  May 18, 2010 1:43:16 PM sun.rmi.server.LoaderHandler loadClass
>  > >  FINER: RMI TCP Connection(8)-10.48.43.157: (thread context class
>  > loader:
>  > >  org.apache.jmeter.DynamicClassLoader@4cb162d5)
>  > >  May 18, 2010 1:43:16 PM sun.rmi.server.LoaderHandler loadClass
>  > >  FINER: RMI TCP Connection(8)-10.48.43.157: class
>  > >  "org.apache.jmeter.samplers.StandardSampleSender" found via thread
>  > context
>  > >  class loader (no security manager: codebase disabled), defined by
>  > >  org.apache.jmeter.DynamicClassLoader@4cb162d5
>  > >  May 18, 2010 1:43:16 PM sun.rmi.server.LoaderHandler loadClass
>  > >  FINE: RMI TCP Connection(8)-10.48.43.157: name =
>  > "java.util.LinkedList",
>  > >  codebase = ""
>  > >  May 18, 2010 1:43:16 PM sun.rmi.server.LoaderHandler loadClass
>  > >  FINER: RMI TCP Connection(8)-10.48.43.157: (thread context class
>  > loader:
>  > >  org.apache.jmeter.DynamicClassLoader@4cb162d5)
>  > >  May 18, 2010 1:43:16 PM sun.rmi.server.LoaderHandler loadClass
>  > >  FINER: RMI TCP Connection(8)-10.48.43.157: class "java.util.LinkedList"
>  > >  found via thread context class loader (no security manager: codebase
>  > >  disabled), defined by null
>  > >  May 18, 2010 1:43:16 PM sun.rmi.server.LoaderHandler loadClass
>  > >  ...
>  > >
>  > >  (... classpath ...)
>  > >  May 18, 2010 1:43:16 PM sun.rmi.server.LoaderHandler loadClass
>  > >  FINER: RMI TCP Connection(8)-10.48.43.157: (thread context class
>  > loader:
>  > >  org.apache.jmeter.DynamicClassLoader@4cb162d5)
>  > >  May 18, 2010 1:43:16 PM sun.rmi.server.LoaderHandler loadClass
>  > >  FINER: RMI TCP Connection(8)-10.48.43.157: class
>  > >  "org.apache.jmeter.samplers.RemoteTestListenerWrapper" found via thread
>  > >  context class loader (no security manager: codebase disabled), defined
>  > by
>  > >  org.apache.jmeter.DynamicClassLoader@4cb162d5
>  > >  [Many repeats of above sections]
>  > >
>  > >  Starting the test on host 10.48.43.160:11001 @ Tue May 18 13:43:16 PDT
>  > 2010
>  > >  (1274215396218)
>  > >  Finished the test on host 10.48.43.160:11001 @ Tue May 18 13:43:17 PDT
>  > 2010
>  > >  (1274215397024)
>  > >
>  > >
>  > >
>  > >  ...Any insight is very helpful.
>  > >
>  > >  Cheers ~
>  > >
>  >
>
> > ---------------------------------------------------------------------
>  > To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
>  > For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>  >
>  >
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message