jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deepak Shetty <shet...@gmail.com>
Subject Re: jmeter uploading a file
Date Thu, 29 Apr 2010 01:01:57 GMT
My reading is that this shouldnt really make a difference . do you know what
error you get on the server side?
> Replaying it fails also.
What does the HTTP sampler have? And do you get any errors in the logs?  Is
the file shown correctly in the send files with request? if you give an
absolute path , it should honor it.  Add a view results tree listener and
see if you can see any error message that the application sends or whether
any previous request fails?
You might try changing the type of sampler (to httpclient) and see if it
makes a difference


On Wed, Apr 28, 2010 at 5:00 PM, Gil Novak <Gil.Novak@verizon.net> wrote:

> I am testing an app that has a file upload feature, which works when I do
> it
> manually.  When I try to record it via the http proxy, the action fails.
> What is it about the proxy that causes a modification of what its sniffing?
> Replaying it fails also.  I'm tried supplying the path, omitting it, moving
> the file to the jmeter root, moving the file to the cwd, etc.  The only
> thing I can think of is that when I compare what JMeter sends in the
> multipart post to what Fiddler sniffed when I do it manually, is that
> JMeter
> adds two lines to each part that isn't there normally:
>
> -----------------------------7d159c1302d0y0
> Content-Disposition: form-data; name="PROC"
> Content-Type: text/plain; charset=UTF-8
> Content-Transfer-Encoding: 8bit
>
> AWUISubmitConvertLeadToTalentDupeCheck
> -----------------------------7d159c1302d0y0
> Content-Disposition: form-data; name="submitType"
> Content-Type: text/plain; charset=UTF-8
> Content-Transfer-Encoding: 8bit
>
> Enter
> -----------------------------7d159c1302d0y0
>
>
>
> A normal sniffing of the multipart post request looks like this:
>
>
>
> -----------------------------23805158906729
> Content-Disposition: form-data; name="PROC"
>
> AWUISubmitShortApplication
> -----------------------------23805158906729
> Content-Disposition: form-data; name="jobID"
>
> 8439573489527
> -----------------------------23805158906729
> Content-Disposition: form-data; name="viralBlast"
>
> false
> -----------------------------23805158906729
>
>
> So, my questions are:  Are the two additional lines (Content-Type, and
> Content-Transfer-Encoding) per part what's causing the problem?
>
> If so, how do I get rid of them?  If not, any other ideas?
>
> Thanks,
> Gil Novak
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message