jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jatin <daveyja...@gmail.com>
Subject Re: JMeter Latency Showing incorrect ?
Date Sun, 10 Jan 2010 06:11:08 GMT
I was testing from my home laptop. My internet speed is 256 kbps. I 
recorded the home page of google.com and was replaying it which had 9 
samplers to access all the contents of the home page. I am confused on 
one point , the Elapsed time is mostly above 400ms for the first sampler 
where as the latency for this sampler is always 0 no matter how many 
times i loop. Both Elapsed time and latency have one thing in common 
which is that both take into account the delay happening because of the 
response getting from across the internet, then how come latency is 0 
all the time while the elapsed time is more than 400ms for most of the time.

Thanks
Jatin

Deepak Shetty wrote:
> if you are testing this out within your intranet , its possible you could
> see extremely low or zero values.
> regards
> deepak
>
> On Sat, Jan 9, 2010 at 2:59 AM, Jatin <daveyjatin@gmail.com> wrote:
>
>   
>> Hi all
>>
>> I had a recorded script that will access the home page of a site. The
>> listener that i was using was a graph results listener. I wanted to save the
>> results in a csv file for only two variables namely: latency and Elapsed
>> time. So in the configure dialog only selected these two parameters and
>> obtained a csv file.
>>
>> My test plan organization was comprised of 9 HTTP samplers in one thread
>> group with all the samplers put into a loop controller looping forever. For
>> all the tests that were looping in the controller i noticed that for the
>> first sampler the latency was always 0 even though the elapsed time was
>> around 400ms but not less than that. Is the latency value correct since for
>> both these parameters the response has to be fetched from the server and
>> there could be delay in receiving the response. Please let me know if i am
>> missing something here.
>>
>> Some test run samples are as below :
>>
>> 459,0
>> 140,137
>> 63,40
>> 179,134
>> 137,137
>> 120,120
>> 53,39
>> 40,40
>> 113,113
>> 275,0
>> 157,154
>> 62,40
>> 540,144
>> 149,148
>> 33,33
>> 53,38
>> 37,37
>> 113,113
>> 470,0
>> 159,155
>> 62,39
>> 178,133
>> 176,176
>> 120,120
>> 54,39
>> 38,37
>> 113,113
>>
>>
>> Thanks
>> Jatin
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
>> For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>>
>>
>>     
>
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message