jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Cookies issue with HTTPS request
Date Wed, 15 Apr 2009 20:06:11 GMT
On 15/04/2009, Ryan Miling <rmiling@bzzagent.com> wrote:
> I have included an HTTP request into one of my JMeter tests where the
>  request made is a log-in (POST) and the protocol is HTTPS. The request
>  works fine, meaning that I downgraded Java 1.6 to 1.5 so the HTTPS
>  request works, but the real issue at hand is cookies.
>
>  I included an HTTP Cookie Manager at the top of the test plan and have
>  run under all possible settings for the element, but I am still unable
>  to store cookies.

The Cookie Manager does not show server cookies, only manually entered cookies.

>  The site I am making the HTTPS request to spits out
>  that 'Cookies are required' and to enable them.
>
>  Can anyone help me with this valiant effort? I have gone through other
>  mailing list entries, but none had a clear-cut response that worked.
>

Have you used the Tree View Listener to see what cookies the server is
sending, and whether any are being sent back?

If some are not being sent back, check whether the correct domain etc.
are being set by the server.

The only other possibility is that some (or all) cookies are being
generated by Javascript.

Try comparing what a browser sends with what JMeter sends.


>
>  Thanks,
>
>
>  Ryan
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message