jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wenqatesh <wenqat...@gmail.com>
Subject Re: MIME multipart/form-data POST problem
Date Fri, 06 Mar 2009 17:19:36 GMT

Pls try omitting the parameter name and also removing the encoding options...




bc9ams wrote:
> 
> Hi,
> 
> I've got a problem trying to run a test plan in JMeter which contains a
> multipart/form-data POST. For some reason the web server does not respond
> with the expected response when JMeter does the POST (which was recorded
> with the proxy). I've used wireshark to compare the JMeter POST and one in
> a
> webbrowser and the differences seem to be in the format of the form-data.
> 
> The web browser request form-data looks like this:
> 
> -----------------------------17807242114310
> Content-Disposition: form-data; name="xx1"
> 
> 15
> -----------------------------17807242114310
> Content-Disposition: form-data; name=xx2"
> 
> 
> 
> The equivelant part of the request in Jmeter looks like this:
> 
> 
> -----------------------------7d159c1302d0y0
> Content-Disposition: form-data; name="xx1"
> Content-Type: text/plain; charset=ISO-8859-1
> Content-Transfer-Encoding: 8bit
> 
> 15
> -----------------------------7d159c1302d0y0
> Content-Disposition: form-data; name="xx2"
> Content-Type: text/plain; charset=ISO-8859-1
> Content-Transfer-Encoding: 8bit
> 
> Is there any way I can get Jmeter to use the format of the webbrowser?
> 
> Thanks
> 
> 


-----
Thanks,
Venkadesh=)
-- 
View this message in context: http://www.nabble.com/MIME-multipart-form-data-POST-problem-tp22362240p22376761.html
Sent from the JMeter - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message