jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Jmeter proxy recoring not showing cookie
Date Tue, 24 Feb 2009 17:24:29 GMT
On 24/02/2009, Mordechai <mr.happy.snappy@gmail.com> wrote:
>
>  Hi,
>
>  After reading your posts I wanted to better describe the problem I'm having.
>
>  Problem: When executing a test plan that uses a cookie to store the session
>  id,
>  the number of users who log into the test application successfully are not
>  consistent.
>  My Test plan executes correctly with 1- 5 threads.
>  When more than 5 threads are used I notice that some of the users do not log
>  in correctly.

That could perhaps be due to a fault in the server, or an error in the
CSV data used to define the users.

>  Correctly means they are shown in Information Server console -> active
>  sessions
>  as an active connection.  Correctly also means that these users do not fail
>  against assertions
>  that check for specific html in request response to assert that there logged
>  in.
>
>  When I check the View Results Tree, I am able to see that a user logged in
>  correctly because
>  I have assertions that check for expected html in a response like "Welcome".

OK.

>  Application:
>  A snippet of the first few requests are the following:
>  -TestPlan
>  --Threadgroup
>  ---CSV

What is the CSV element used for?

>  ---UserParameter
>  ---View Results Tree
>  ---Http Cookie Manager
>  ---Http Header Manger ( contains entry User-Agent:
>  Mozilla/4.79[en](X11;U;Linux 2.2.12 i386)
>  ---Aggregate Report
>  +--Transactoin: Script Name
>  +---Transaction: LogIn Page
>  -----/appname
>  -----/appname/   (Header Recieved Set-Cookie JSESSIONID=00PW8JoNQgW:-1;
>  Path=/
>  -----/appname/searchform.do (Header sent with JSESSIONID)

Does it send the correct cookie as received above?

>  -----/appname/login.jsp
>  -----/appname/j_acegi_security_check.do (user id / pw sent here )
>
>
>
>  The cookie received in /appname/ I do not see in any headers in Jmeter.

What do you mean?
This does not agree with "(Header sent with JSESSIONID)", nor with the
output from the http debugger shown below.

>   As I had posted earlier I incorrectly expected to see it sent as a part of
>  subsequent header requests.  Using other http debuggers
>   I can see that the next request contains the following header:
>
>
>  (Request-Line)  GET /appname/searchForm.do HTTP/1.1
>  Accept  image/gif, image/x-xbitmap -shortened for this email- */*
>  Accept-Encoding gzip, deflate
>  Accept-Language en-us
>  Connection      Keep-Alive
>  Cookie  JSESSIONID=00PW8JoNQgW:-1

So the cookie is sent. Is the value the expected value?

>  Host    pmachine-x:9080
>  User-Agent      Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; Avant
>  Browser)
>
>  The cookie jsession cookie is sent to the server in
>  /appname/searchform.do

Is it the correct value?

>  When debugging my script through View_Results Tree I can see
>  that the requests are sending a jsession cookies.
>
>  What am I dong wrong?  When should I be using a header manager?

When you need to send a header (other than a cookie).

>  My problem is very very similiar to thread:
>  http://marc.info/?l=jmeter-user&m=100867164302881&w=2
>  except the fix did not work for me.

I don't see the relevance myself.

>
>  Pictures of test plan
>  https://www.getdropbox.com/gallery/398664/1/Jmeter-Issues?h=2a7cab
>
>  a) How do you appropriately interact with cookies in this situation? ( I'm
>  using a cookie manager)
>  b) What obvious mistake am I making?

What does the server say on the page which normally has the welcome message?

That may give a clue as to what is going on.

>  Thank you for your patience and help in advance.
>  Mordechai
>
>
>
>
>
>  On 23/02/2009, Mordechai <mr.happy.snappy@gmail.com> wrote:
>  >
>
>  There's something wrong with the way previous messages are being
>  quoted when you reply.
>
>  For some reason an extra > is being added to your responses. This
>  makes it very difficult to follow the thread.
>
>  >
>  >  sebb-2-2 wrote:
>  >  >
>  >  > On 23/02/2009, Mordechai <mr.happy.snappy@gmail.com> wrote:
>  >  >>
>  >  >>
>  >  >>
>  >  >>  sebb-2-2 wrote:
>  >  >>  >
>  >  >>  > On 23/02/2009, Mordechai <mr.happy.snappy@gmail.com> wrote:
>  >  >>  >>
>  >  >>  >>  Hi there,
>  >  >>  >>
>  >  >>  >>  Thanks for the reply.  I am using the cookie manager.  It
seems
>  > the
>  >  >>  >> jsession
>  >  >>  >>  is sent in a cookie immediately before the log in page.
>  >  >>  >
>  >  >>  > Does the test plan include the page before the login page?
>  >  >>  >
>  >  >>
>  >  >> >     - Yes the 1st request contains the cookie JSESSIONID
>  >  >>
>
>
> --
>  View this message in context: http://www.nabble.com/Jmeter-proxy-recoring-not-showing-cookie-tp22150874p22184707.html
>
> Sent from the JMeter - User mailing list archive at Nabble.com.
>
>
>  ---------------------------------------------------------------------
>  To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
>  For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message