jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Temoor A. Janjua" <tjan...@unicon.net>
Subject Re: Target host on Vmware
Date Fri, 19 Dec 2008 00:04:40 GMT
I am using Jmeter 2.3.2.

Using Port 80 cannot help resolve this problem. My app is running on 
vmware where i have to specify a particular port which a particular jvm 
is using (8000 in my case).

However, i have fixed the problem by replacing the value of Host 
parameters from "${__property(hostname)}" to 
"${__property(hostname)}:${__property(httpPort)}" for all the browser 
derived headers under every sampler.

Thanks,
TJ

sebb wrote:
> On 17/12/2008, Temoor A. Janjua <tjanjua@unicon.net> wrote:
>   
>> I provided the Port as -JhttpPort=8000 and hostname as
>> -Jhostname=tj-web-8.service.com while starting up the
>> Jmeter GUI from the command line.
>>     
>
> OK
>
>   
>>  I am using the hostname and port properties in my sampler as: Server Name
>> or IP: ${__property(hostname)} , Port Number: ${__property(httpPort)}
>>     
>
> OK.
>
>   
>>  I have used the same test plan with the target host running without a
>> vmware and the test plan works just fine with a hostname such as
>> tj-web-8.service.com so i am not sure where these "[]" characters are coming
>> from.
>>     
>
> Try using port 80 with a normal host.
>
> Which version of JMeter?
>
> Any error messages in the log file?
>
>   
>>  Thanks,
>>  TJ
>>
>>
>>  sebb wrote:
>>
>>     
>>> On 16/12/2008, Temoor A. Janjua <tjanjua@unicon.net> wrote:
>>>
>>>
>>>       
>>>> Hi - My target host is running on vmware so i have a hostname like
>>>> "tj-web-8.service.com:8000".
>>>>
>>>>
>>>>         
>>> That is not a hostname (nor a URL).
>>>
>>>
>>>
>>>       
>>>> When i specify the hostname as a property on
>>>> the command line such as
>>>> -Jhostname=tj-web-8.service.com:8000 and start my
>>>>         
>> jmeter
>>     
>>>>         
>>> That just defines the JMeter property "hostname".
>>>
>>>
>>>
>>>       
>>>> GUI, my jmeter script throws hostname errors and i see the hostname in
>>>>         
>> the
>>     
>>>> "View results Tree" listener for the samplers as
>>>> "http:\\[tj-web-8.service.com:8000]\...", Can somebody
>>>> please tell me why the hostname has been put between the brackets "[]"
>>>> causing the errors.
>>>>
>>>>
>>>>         
>>> JMeter does not add those characters, so there must be an error in the
>>> test plan.
>>>
>>>
>>>
>>>       
>>>> I have already tried supplying port and hostname
>>>> separately  but that did not work for me either.
>>>>
>>>>
>>>>         
>>> Exactly how did you provide the port?
>>>
>>> And how are you using the hostname and port properties in the sampler?
>>>
>>>
>>>
>>>       
>>>>  Thanks,
>>>>  TJ
>>>>
>>>>
>>>>         
>> ---------------------------------------------------------------------
>>     
>>>>  To unsubscribe, e-mail:
>>>> jmeter-user-unsubscribe@jakarta.apache.org
>>>>  For additional commands, e-mail:
>>>> jmeter-user-help@jakarta.apache.org
>>>>
>>>>
>>>>
>>>>
>>>>         
>>>       
>> ---------------------------------------------------------------------
>>     
>>> To unsubscribe, e-mail:
>>>       
>> jmeter-user-unsubscribe@jakarta.apache.org
>>     
>>> For additional commands, e-mail:
>>>       
>> jmeter-user-help@jakarta.apache.org
>>     
>>>
>>>
>>>
>>>       
>> ---------------------------------------------------------------------
>>  To unsubscribe, e-mail:
>> jmeter-user-unsubscribe@jakarta.apache.org
>>  For additional commands, e-mail:
>> jmeter-user-help@jakarta.apache.org
>>
>>
>>     
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>
>
>
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message