jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Asynchronous HTTP request
Date Mon, 14 Jul 2008 14:52:47 GMT
On 14/07/2008, Paule Zaksauskiene <PauleZ@enigmatec.net> wrote:
> Hi,
>
>  Thanks for a quick response.

Did my suggestion work?

>  Basically, the url (if I type it manually on the browser), returns empty
>  page. The url format is the following:
>
>  http://localhost:8443/opath/blueprintAccess/commission(id,parameters)?id
>  ={"oid":{"type":"com.enigmatec.ems.server.dtoImpl.BlueprintImpl","key":0
>  }}&parameters={"java.io.Serializable:[]}
>  The request does not return any response. Therefore, Page Info shows "0
>  kB".
>

There is still a response - e.g. there are response headers - however
the body of the response is empty.

>  The sampler results are successful for other same style requests, which
>  return at least one char.
>

It's upto the server what Response Code it returns.
It could return 200 with an empty body.

And it can return a non-empty body with a 404.

BTW, the subject says "Asynchronous" HTTP - what has this to do with
asynchronous requests?

>  Thanks,
>
> Paule
>
>
>  -----Original Message-----
>  From: Fitzpatrick, Adrian [mailto:adrianf@revenue.ie]
>  Sent: 14 July 2008 15:10
>  To: JMeter Users List
>  Subject: RE: Asynchronous HTTP request
>
>
>  Hi,
>
>  HTTP GET should return a response - can you provide a bit more detail on
>  what
>  you are trying to do?
>
>  Rgds,
>
>  Adrian
>
>  -----Original Message-----
>  From: Paule Zaksauskiene [mailto:PauleZ@enigmatec.net]
>  Sent: 14 July 2008 15:06
>  To: jmeter-user@jakarta.apache.org
>  Subject: Asynchronous HTTP request
>
>
>  Hello,
>
>
>
>  In my Test Plan, I have got the GET HTTP request, which is not supposed
>  to  return any response.
>
>  However, when I run the test, the Sampler Result returns error as it
>  looks for a response, but receives the 404.
>
>  Please, see the answer below:
>
>
>
>  Thread Name: Thread Group 1-2
>
>  Sample Start: 2008-07-14 14:58:48 BST
>
>  Load time: 5
>
>  Latency: 0
>
>  Size in bytes: 0
>
>  Sample Count: 1
>
>  Error Count: 1
>
>  Response code: 404
>
>  Response message: Not Found
>
>
>
>  Response headers:
>
>  HTTP/1.1 404 Not Found
>
>  Date: Mon, 14 Jul 2008 13:58:48 GMT
>
>  Server: Jetty/5.1.3 (Windows XP/5.1 x86 java/1.5.0_14
>
>  Content-Type: text/javascript;charset=ISO-8859-1
>
>  Connection: close
>
>
>
>  How can I change HTTP request settings to make this request not to fail
>  in such case?
>
>
>
>  Thanks,
>
>  Paule Zaksauskiene
>
>
>
>
>
>  ************************
>
>  This message has been delivered to the Internet by the Revenue Internet
>  e-mail service (OP)
>
>  *************************
>
>  ---------------------------------------------------------------------
>  To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
>  For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>
>
>  ---------------------------------------------------------------------
>  To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
>  For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message