jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Brown" <da...@davidwbrown.name>
Subject Re: telnet to slave @ 1099 OK but Connection refused from jmeter-server
Date Fri, 01 Feb 2008 18:48:41 GMT
Hello Sebb, thanks for the speedy reply. Your right I do not see a page (bad choice of terms).
But, I do see a very reasonable return for the telnet session connection to the slave:

david@worktop:~$ telnet 192.168.1.2 1099
Trying 192.168.1.2...
Connected to 192.168.1.2.
Escape character is '^]'.

I do the same thing when trying to <ping> an email server (SMTPd). I feel reasonably
comfortable that I have no firewall or network issues. The 127.0.0.1 loopback is what the
jmeter-server is looking for and even though I have introduced the JMETER_CMD_LINE_ARG as
shown below I still get <Connection refused>.

I have defined the HOST variable and placed it in jmeter-server.sh:

HOST="-Djava.rmi.server.hostname=192.168.1.2"
java $SERVER $JVM_ARGS -jar `dirname $0`/ApacheJMeter.jar $HOST -s "$@"

The jmeter-server.log on the slave clearly shows the non-loopback host IP address was accepted
and set the RMI hostname property accordingly. But, once the test starts it reverts back to
the loopback address namely: 127.0.0.1

Logs:

INFO jmeter.samplers.RemoteListenerWrapper: Test Started on 192.168.1.2
ERROR jmeter.samplers.RemoteLintenerWrapper: testStarted(host) java.rmi.ConnectException:
connection refused to host: 127.0.0.1

My question is how does the loopback creep back into the process since JMeter has been configured
to use another IP? Do I need to disable the loopback altogether at interface: lo?

What more information or diagnostic may I perform to gather better informational help?

Tests and monitoring pending: please advise, David.


sebb wrote ..
> You should not see a page when telnetting to the RMI server on 1099
> 
> On 01/02/2008, David Brown <david@davidwbrown.name> wrote:
> > Hello JMeter gurus, Peter Lin et. al. and users, I have previously posted a similar
> problem and it was ignored probably for good reason. I am able to telnet <slave-host>
> 1099 and I get the expected page as if I were connecting to an email server @ port
> 25. The connection is of course the RMI listener running for the JMeter slave @
> port 1099. However, when I run the Test Plan all I get is Connection refused. I
> applied the Sergey Ten tips (from the JMeter remote test doco) in the jmeter shell
> script but it affords no change. Googling for this problem returns very few useful
> tips. Any and all suggestions, advice, rants or raves welcomed. Please advise,
> David.
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
> >
> >
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jmeter-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message