jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Koschara <asf.u...@wfredk.com>
Subject Re: JMeter startup failure on new XP machine, problem went away and came back
Date Thu, 09 Aug 2007 23:28:40 GMT
On 8/9/2007 6:11 PM, sebb wrote:
> On 09/08/07, Fred Koschara <asf.user@wfredk.com> wrote:
>> This error occurred when I first installed JMeter (jakarta-jmeter-2.3RC3).  I
>> poked and prodded, did some reinstallation, tried different things, and suddenly
>> it worked, without my being able to explain why.  It worked for a couple of
>> days.  I made the mistake of hitting the "close" button on the DOS box JMeter
>> was running in, which also took down the GUI window I had test results displayed
>> in.  When I tried to run JMeter again, the error had returned.  I've reinstalled
>> Java (JDK and JRE), and JMeter, and this problem won't go away.
>>
>> C:\Programs\Java\JAKART~1.3RC\bin > jmeter
>> Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/jorphan/ut
>> il/JMeterException
>>         at java.lang.Class.getDeclaredConstructors0(Native Method)
>>         at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
>>         at java.lang.Class.getConstructor0(Unknown Source)
>>         at java.lang.Class.newInstance0(Unknown Source)
>>         at java.lang.Class.newInstance(Unknown Source)
>>         at org.apache.jmeter.NewDriver.main(NewDriver.java:181)
>>
>> Wed 08/08/2007 15:12:38.48 Microsoft Windows XP [Version 5.1.2600]
>>
>> Summary of what I've done:
>>
>> brand new development system, Sony Vaio VGN-BX660P 1GB RAM Intel Core2 1.82GHz
>> installed WAMP 1.7.2
>> ...
>> installed jdk-6u2-windows-i586-p.exe JDK 6 Update 2: jdk1.6.0_02, jre1.6.0_02
>>
>> Neither JAVA_HOME nor CLASSPATH were set by the Java installation.  I set
>> JAVA_HOME=C:\Programs\Java\jre1.6.0_02 to use the JRE.
>>
>> I tried to figure out what was meant in the "2.3 Installation" section of
>> http://jakarta.apache.org/jmeter/usermanual/get-started.html where it says
>> "simply unzip the zip/tar file into the directory where you want JMeter to be
>> installed" and first unzipped the archive into a temporary directory, then
>> copied the contents of the bin, etc. directories to the corresponding JRE ones
>> (since that's where I'd set JAVA_HOME to be).
> 
> That may be the problem.
> 
> Just unzip the zip file into a directory - e.g. into C:\ - this will
> create the directory  C:\jakarta-jmeter-2.3RC3 and all the JMeter
> files will be below that. Do not copy the files into the JRE
> directories.
> 
> Don't extract JMeter into a path with any spaces in it or remote mode
> will not work.

JMeter was working (when it was working) with it mixed in with the JRE the first 
time.  In the second installation (see the following paragraphs), I unpacked 
JMeter into its own directory (C:\Programs\Java\jakarta-jmeter-2.RC3), and 
that's where it's not working from now.

I had noted the "path with no spaces" warning in the JMeter installation 
directions, which is why I'd installed it under "C:\Programs" instead of under 
"C:\Program Files" in the first place.

>> Once I figured out where jmeter.bat was, I opened a DOS box in that directory
>> and tried running "jmeter" - which returned the error output illustrated above.
>>  I tried hacking at the problem, reinstalling stuff, rebooting, reinstalling
>> more - and suddenly it started working, for reasons unknown.  Unfortunately, I
>> didn't keep notes of all the steps I went through, so I've got no clue what I
>> changed that caused it to start working.
>>
>> When the bug returned, I tried reinstalling Java, discovered there were at least
>> two copies on the machine, and deinstalled both Java and JMeter.  In doing the
>> reinstall, I put Java back in the same place I'd had it before, and unpacked
>> JMeter into a separate directory, so its files are no longer mixed in with the
>> JRE ones.  I'm still getting the same error, and cannot proceed with *ANY* testing.
>>
>> I tried looking at the source code, but without studying the whole JMeter
>> application, I don't think I'd know where to look for this problem.
>>
>> I've Googled for "Exception in thread "main" java.lang.NoClassDefFoundError"
>> which returned lots of "set CLASSPATH" types of results, and tried a variety of
>> CLASSPATH settings, none of which have made any difference.  I now have it as:
>> .;C:\Programs\Java\jre1.6.0_02\lib;C:\Programs\Java\jakarta-jmeter-2.3RC3\lib;C:\Programs\Java\httpunit-1.6.2\jars;C:\Programs\Java\httpunit-1.6.2\lib;
>>
>> I also Googled "NoClassDefFoundError: org/apache/jorphan/util/JMeterException"
>> which only returned pages about BeanShell, which seems pretty irrelevant here.
>>
>> What am I doing wrong here?  Did I misinstall something?  Is there a problem
>> with using JMeter with Java 6 Update 2?  (Should I be asking these questions
>> somewhere at Sun?)  Is there a better way to look for useful suggestions?  Did
>> closing the DOS box with JMeter running in it really break something at the
>> system level, as it appears???
>>
>> Any useful suggestions will be sincerely appreciated!!

________________________________________________________________________
Investment quality fine art prints - http://LimitedEditionPhoto.com
	Officially opened March 30, 2007
FREE space history newsletter - http://L5Development.com/SpaceHistoryNews.php
For your daily dose of art, try http://PhotoByFred.com
FKE Internet, Web hosting for space related business - http://FKEinternet.com
	Domain registration - $15.95/year, $29.95 for 2 years
My personal Web page is http://wfredk.com - stop by some time!

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message