jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Indraneel Chowdhury <indraneel_chowdh...@yahoo.com>
Subject Re: Problems in distributed testing with jmeter
Date Thu, 31 May 2007 10:23:40 GMT
OK, I solved the first problem. But now I have another one :-). The path to rmiregistry was
wrong (I don't have any idea how the window title showed "j2sdk1.4.2\jre\bin\rmiregistry.exe").
I changed the path to rmiregistry and it worked. 
I have one slave with IP 172.16.40.117 and one master with IP 172.16.40.125. Both are on the
same subnet, the default gateway being 172.16.40.1
Now when I start the server the log says:
2007/05/31 15:30:18 INFO  - jmeter.engine.RemoteJMeterEngineImpl: Bound to registry on port
9191 
When I start the master, that runs fine too and the log says:
2007/05/31 15:30:18 INFO  - jmeter.engine.ClientJMeterEngine: sent host 172.16.40.117:9191
2007/05/31 15:30:18 INFO  - jmeter.engine.ClientJMeterEngine: sent test

The slave jmeter log thereafter says:
2007/05/31 15:31:15 INFO  - jmeter.engine.RemoteJMeterEngineImpl: received test tree 
2007/05/31 15:31:15 INFO  - jmeter.engine.RemoteJMeterEngineImpl: running test 
2007/05/31 15:31:15 INFO  - jmeter.engine.StandardJMeterEngine: Running the test! 
2007/05/31 15:31:15 INFO  - jmeter.samplers.RemoteListenerWrapper: Test Started on 172.16.40.117:9191


But then the whole thing bombs saying:
2007/05/31 15:31:16 ERROR - jmeter.samplers.RemoteListenerWrapper: testStarted(host) java.rmi.ConnectException:
Connection refused to host: 172.16.14.158; nested exception is: 
    java.net.ConnectException: Connection refused: connect
I don't understand how the host 172.16.14.158 comes in the picture. In the end the log says:
2007/05/31 15:40:25 INFO  - jmeter.engine.StandardJMeterEngine: Test has ended 

though there are no result (jtl) files. I am completely perplexed. Please help.

Thanks and regards
Indraneel


----- Original Message ----
From: Matt <mattmoran76@gmail.com>
To: JMeter Users List <jmeter-user@jakarta.apache.org>
Sent: Thursday, May 31, 2007 2:59:52 PM
Subject: Re: Problems in distributed testing with jmeter

Nope that looks good.  Is the Windows firewall blocking the rmi port?

On 31/05/07, Indraneel Chowdhury <indraneel_chowdhury@yahoo.com> wrote:
>
> I don't think you have to explicitly start "rmiregistry" on windows. When
> I start jmeter server, I get a window with title:
> j2sdk1.4.2\jre\bin\rmiregistry.exe . Am I missing something?
>
> Thanks and regards
> Indraneel
>
>
>
>
>
>
> ____________________________________________________________________________________
> Boardwalk for $500? In 2007? Ha! Play Monopoly Here and Now (it's updated
> for today's economy) at Yahoo! Games.
> http://get.games.yahoo.com/proddesc?gamekey=monopolyherenow







       
____________________________________________________________________________________Boardwalk
for $500? In 2007? Ha! Play Monopoly Here and Now (it's updated for today's economy) at Yahoo!
Games.
http://get.games.yahoo.com/proddesc?gamekey=monopolyherenow  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message