jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christensen, Alan" <alan.christen...@hp.com>
Subject RE: Question for proxy server
Date Fri, 09 Feb 2007 23:51:30 GMT
Are you trying to record scripts while connected via a VPN?  I had
problems today forcing IE to go through the jmeter proxy when connected
over a VPN.  I set up IE to use "localhost" when I want to record
scripts.  This works fine when directly connected to the Internet.
However, this doesn't seem to work when connected over a VPN.  I think
the problem is that IE won't allow me to force the usage of "localhost"
when connected via a VPN.  I can check the box in IE/tools/Internet
options/connections to use "localhost" as the proxy, but it detects that
I am using a VPN and ignores the setting.  There is a note next to the
checkbox that says that the setting will not work over a VPN.  I never
noticed this text until I ran into this problem.
 
I don't know if you are testing over a VPN, but if so, this could be
your problem.  I think Firefox may allow you to force the usage of
localhost as the proxy in this configuration, but I have yet to try it.
 
 

________________________________

From: Jian Tong [mailto:TongJ@Toronto.CBC.CA] 
Sent: Friday, February 09, 2007 2:01 PM
To: JMeter Users List
Subject: Question for proxy server


Hi,
 
I am using Jmeter 2.2, the proxy server used to be working. But I just
re-try it and it didn't record anything. My proxy server setting is
below:
 
Test Plan 
-Thread Group
--Http Request Defaults: 
  server name: www.qa.nm.cbc.ca
  protocal: http
  port: 80
Workbench
-Proxy Server
 Port: 9090
 Target Controller: Test Plan->Thread Group
 Patterns to Includ: .*\.html
 Patterns to exclud: .*\.gif, .*\.jpg, .*\.png, .*\.jsp
 
Anybody can tell me where the problem is ? Or is there anybody ever
experiencing the same problem ?
 
Thanks
 
Jian Tong

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message