jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jake Jacobson" <jakecjacob...@gmail.com>
Subject Newbie question about JMeter
Date Thu, 11 Jan 2007 18:33:26 GMT
Hi,

I am trying to build a test plan to load test our search appliance.  I
have a file with search terms, 1 per line that I want to submit
against the application.  I want to go through the list once and when
I reach the end of file, the test would end.  I am having 2 issues
that I need help with.

1.  My test runs forever without advancing through the list.  I keep
submitting the first term from the list.

2.  It seems that each HTTP Request is sending 3 requests and I would
only expect to see 1.

I have configured the following items.

Main Thread Group
  Number of Threads -> 1
  Ramp-Up Period -> 0
  Loop Count -> 0

HTTP Request Defaults
  Server name -> Url for my search appliance
  Path -> /search
  Send Parameters with the Request:
    output -> xml
    client -> mysite
    site -> mysite

CSV Data Set Config
  Filename -> searchTerms.txt
  Variable Names -> QUERY
  Delimiter -> \n
  Recycle on EOF -> False

While Controller
  Condition ${QUERY} != "<EOF>"

Then inside the while controller I have and HTTP Request
  Method -> Post
  Send Parameters with the Request:
    q -> ${QUERY}

I have then added the "View Results Tree" and I see that for each
"HTTP Request" it appears to be hitting the server 3 times.
  1.  To the search page with the correct parameters.  This is done as
a Post and it is the one I want.
  2.  To http://mysearch.com:80/  I don't know why.  This is done as a GET
  3.  To
http://mysearch.com:80/search?output=defaultValue&client=defaultValue&site=defaultValue
Again, This is done as a GET and I don't understand why?

Thanks for your help.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message