jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: user parameters pre-processor JavaScript function
Date Wed, 03 Jan 2007 20:22:30 GMT
Odd - looks like the CSV Dataset has to be AFTER the User Parameters.

Not yet sure if this is a bug or a deliberate feature...

Anyway, try swapping them and see if this helps.

On 03/01/07, Gary K. Avery <garyavery@verizon.net> wrote:
> hello,
>
> i seem to have run into a snag and not sure whether it is a timing
> restriction or something else.
>
> i have a thread group with a CSV Data Set Config element which
> is reading in from a file and assigning some variables (e.g., A, B, C).
> that seems to be working fine.
>
> i then have a User Parameters Pre-Processor element immediately following
> the config element which is trying to perform arithmetic on two of the
> variables, e.g.:
>      ${__javaScript(${A} + ${B})}
>
> however, this is not working.
> works fine if the values are static numerics or even other variables
> defined in
> an earlier User Defined Variables config element.  but, not the
> pre-processor element.
>
> why??
>
> thanks in advance.
>
> gary avery
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message