jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JackBrody <flannanbr...@hotmail.com>
Subject XSLT Windows v's Unix
Date Fri, 15 Dec 2006 16:59:52 GMT

Hi
I having a problem processing XSLT on unix at the moment, it works fine on
windows but when I try process the same file on Unix I keep getting the same
error. I'm wondering does anyone know is there a difference between the two
operating systems that maay cause this problem....if so have you any
solutions 
Most current operating systems have an XSLT processor installed. For
example, Windows XP comes with the MSXML3 library, which includes an XSLT
processor. Earlier versions may be upgraded and there are many alternatives,
see the External Links section.
Seems like JMeter is generating some dodgy XML, but not sure why that
wouldn't fail on Windows also
JMeter uses an XSLT file, jmeter-detail-report.xsl to transform the JMeter
JTL output into a nicely formatted html table of results.
The version of the file which I run with ant-jmeter (as a task in build.xml)
runs well on Windows but fails on Unix with the following exception:
[xslt] Processing /export/home/sfuser/sola/JMeter/JMeterResults.jtl to
/export/home/sfuser/sola/JMeter/JMeterResults_detail.html
[xslt] Loading stylesheet
/export/home/sfuser/sola/JMeter/jmeter-results-detail-report.xsl
[xslt] : Error! Content is not allowed in prolog.
[xslt] : Error!
com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Content is
not allowed in prolog.
[xslt] Failed to process /export/home/sfuser/sola/JMeter/JMeterResults.jtl

BUILD FAILED
/export/home/sfuser/sfv4-client/staging/sfv4client_jmeter.xml:132:
javax.xml.transform.TransformerException:
javax.xml.transform.TransformerException:
com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Content is
not allowed in prolog.

I tried removing spaces, changed the xml prolog in the xsl file, etc but it
still doesn’t work.

Could you suggest what I can do to fix the problem?

cheers 
flannan 

-- 
View this message in context: http://www.nabble.com/XSLT-Windows--v%27s-Unix-tf2828203.html#a7895211
Sent from the JMeter - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message