jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mili Miranda" <milimira...@hotmail.com>
Subject SSL certificate
Date Tue, 11 Jul 2006 19:52:50 GMT
Hi all,
        Once again I'm trying to get a solution for my problem regarding the 
SSL certificate. I saw that lot of people faced a similar situation and so I 
tried the solutions put forth by them. I have tried everything possible, but 
it seems strange that the same solution seems to work for them , but not for 
me.
Let me state the exact steps that I have used in my latest attempt:
1) create brand new keystore
keytool -genkey -keystore <keystore name> -storepass <password> -keypass 
password

2) delete entry so keystore is empty
keytool -delete -keystore <keystore name> -alias mykey -storepass <password>

3) import your CA's root certificate (root alias can be whatever)
keytool -import -keystore <keystore name> -alias <root alias> -file 
<rootcert> -storepass <password> -trustcacerts

4) And then put it in jre/lib/security folder.

5) I then changed the jmeter.properties file accordingly
Uncomment these
ssl.provider=com.sun.net.ssl.internal.ssl.Provider
ssl.pkgs=com.sun.net.ssl.internal.www.protocol

javax.net.ssl.trustStore=C:/jdk1.5.0_07/jre/lib/security/(cert name)
javax.net.ssl.keyStore=C:/jdk1.5.0_07/jre/lib/security/(cert name)

javax.net.ssl.keyStorePassword=changeit


I'm using jdk1.5.0_07 and it is installed in C:/jdk1.5.0_07

I keep getting the error "ERROR - jmeter.util.SSLManager: Couldn't load 
keystore java.lang.Exception: No key found "

Is there something I'm missing out? Please help. It's very important to get 
this resolved for our load testing.

Any help is appreciated.
Thanks



---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message