jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eid.Erik" <Erik....@ftb.ca.gov>
Subject RE: Multiple Cookie Problem
Date Wed, 28 Jun 2006 16:28:04 GMT
Then maybe I am not defining my test correctly.  This is what my test plan looks like:

TestPlan
  |
  -- Thread Group
	|
	-- HTTP Cookie Manager
	|
	-- Once Only Controller
	|	|
	|	-- HTTP Request - Get Login Page
	|	|
	|	-- HTTP Request - Post Login Page
	|		|
	|		-- Assertion (Successful)
	|	
	|-- Simple Controller
	|	|
	|	-- HTTP Request - Get Home Page (Secure Page)
	|		|
	|		-- Assertion (FAILS)
	|	
	|-- Once Only Controller
	|	|
	|	-- HTTP Request - Post Logout Request
	|
	-- View Results Tree
	|
	-- Assertion Results
	|
	-- Aggregate Report
	|
	-- HTTP Request Defaults
	|
	-- Gaussian Random Timer

This test works against my WebSphere Test Environment.  The Test Environment only uses one
cookie.

The assertion for the Home page fails against the z\OS WebSphere because I am being redirected
back to the Login Page.  I do not see the Ltpa_token cookie in any of the requests.

This same test works in JMeter 1.9.1 and I see the Ltpa_token cookie.

I have tested using a Simple Controller instead of the Once Only controller for login and
I still get the same results.


-----Original Message-----
From: Daniel L. Gregoire [mailto:dlg.toastman@gmail.com]
Sent: Wednesday, June 28, 2006 9:04 AM
To: JMeter Users List
Subject: Re: Multiple Cookie Problem


Eid.Erik wrote:
> Hi
>   I have been having a problem with JMeter version 2 on (Including the latest nightly
build).  The issue seems to be that JMeter Cookie Manager does not deal with more than 1 cookie
at a time.  
>
> Scenario:
>   WebSphere 5.1 on z\OS with a Web Application.  HTTPS and J2EE Security is enabled.
 User needs to be Authenticated thru Form-Based authentication to view any page in the application.
 WebSphere is using Top Secret as it Security Service.
>
> When using a browser, I receive two Session Cookies after logging in:  The regular JSESSIONID
cookie and a Ltpa_token cookie.  The LTPA cookie is part of IBM Single Sign-on subsystem.
 It stands for Lightweight Third Party Authentication.  This cookie is used between cells
of the WebSphere instance(supposedly works for other IBM applications but have not tested).
 
>
> In JMeter 2.1 and 2.2, I do not see the Ltpa_token cookie being used in the View Results
Tree - Request Tab.  Only the JSESSIONID is listed under the Cookie Data listing.  
>
> Is this an issue because of Ltpa_token name having an underscore or does JMeter 2.x have
a bug in dealing with more than one cookie?
>
> By the way, JMeter 1.9.1 works with the Ltpa_token cookie.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>
>
>   
I don't know about the underscore, but I have a similar situation
wherein I have two cookies, and JMeter handles them.

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message