jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Proposal: JMeter 2.1.2 to drop support for Java 1.3
Date Mon, 05 Jun 2006 10:00:57 GMT
On 05/06/06, Gaël LHEZ <glhez@glowria.fr> wrote:
> I really don't know why people are still using 1.4 ? (since I learned Java
> with 1.5)
>
> Generics are a great improvment, ...

Indeed.

> Beside, you can compile for 1.4, and use 1.5?

JMeter is built on 1.3/1.4 and runs on 1.5.

I'm not convinced it will be possible to build on 1.5 and still run on 1.4.

>
> (note that I make add on in 1.5, but I don't like to "cast" list/etc)
>
> -----Message d'origine-----
> De : sebb [mailto:sebbaz@gmail.com]
> Envoyé : lundi 5 juin 2006 11:51
> À : JMeter Users List
> Objet : Re: Proposal: JMeter 2.1.2 to drop support for Java 1.3
>
> Unless that can be done without dropping 1.4 support, then no; it
> would cut out a large section of the user population (possibly the
> majority).
>
> And it needs to be possible to and build the code in Eclipse while
> still using the 1.4 libraries.
>
> But of course you can always use 1.5 to build your own add-ons.
>
> S.
> On 05/06/06, Gaël LHEZ <glhez@glowria.fr> wrote:
> > Could you also use generics in Jmeter (java 1.5 feature) which would
> clarify
> > the Java code, and avoid some errors... ? (like for the collection of
> > variable, which I have to cast each time..., etc)
> >
> > -----Message d'origine-----
> > De : sebb [mailto:sebbaz@gmail.com]
> > Envoyé : lundi 5 juin 2006 01:42
> > À : JMeter Users List; JMeter Developers List
> > Objet : Proposal: JMeter 2.1.2 to drop support for Java 1.3
> >
> > We had planned and announced that 2.1.2 would be the last release that
> > supported Java 1.3.
> >
> > However it is proving tedious and time-consuming to fix JMeter so that it
> > compiles under Java 1.3.
> >
> > We know from previous experience that it won't perform well under Java
> > 1.3 - even if it can be built.
> >
> > So I'd like to drop the support for Java 1.3.
> >
> > If there are any major objections to this, please say so ASAP.
> >
> > However supporting Java 1.3 is likely to delay the release considerably
> > (even more than it has been delayed already ...)
> >
> > S///
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
> >
> >
> > --
> > No virus found in this incoming message.
> > Checked by AVG Free Edition.
> > Version: 7.1.394 / Virus Database: 268.8.1/355 - Release Date: 02/06/2006
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>
>
> --
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.394 / Virus Database: 268.8.1/355 - Release Date: 02/06/2006
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jmeter-user-help@jakarta.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message