jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Morten Kristiansen" <morten.kristian...@tracetracker.com>
Subject RE: Hangup when testing remote
Date Thu, 20 Oct 2005 17:41:23 GMT

In the logs, everything looks fine. On the slave machine, the logs says that it runs the tests
and finishes them.
I tried to run the same tests in consolemode without remote flag (-r), and then everything
works fine.

I need to run in console mode since I'm running JMeter from Maven on a nightly basis. I'm
currently working on a Maven
plugin for JMeter that runs JMeter and plots the result in graphs; making it possible to see
the sample results in
a historical view.

Morten


-----Original Message-----
From: Peter Lin [mailto:woolfel@gmail.com]
Sent: Thu 10/20/2005 5:00 PM
To: JMeter Users List
Subject: Re: Hangup when testing remote
 
I've never seen this behavior before since I've never run distributed
testing in console mode. does jmeter correctly run the tests and log the
results?


peter


On 10/19/05, Morten Kristiansen <morten.kristiansen@tracetracker.com> wrote:
>
>
> I'm trying to run some remote tests in headless mode, but jmeter hangs.
> Here's the command I run and output:
>
> ../jakarta-jmeter-2.1.1/bin/jmeter -Jlog_file=jmeter.log-Jupgrade_properties=/upgrade.properties
> -Jsaveservice_properties=/saveservice.properties -n -l /jmeter-
> raw-report.xml -p /jmeter.properties -d . -t /testplan.jmx -r
>
> Output:
>
> Created the tree successfully
> Configuring remote engine for 192.168.12.150:10099<http://192.168.12.150:10099>
> Starting remote engines
> Remote engines have been started
> Tidying up ...
> ... end of run
>
> After the last output line, jmeter hangs. I use port 10099 as RMI, not the
> default 1099. I have checked logs on both master and slave hosts and it all
> seems to work. But it hangs.
>
> Can anyone help?
>
> Morten
>
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message