jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg.Pe...@MDSUK.COM
Subject thread group scheduler confusion...
Date Sun, 07 Aug 2005 09:21:50 GMT
Hi I'm new to all this so please forgive me if the answer is obvious and 
I'm just being daft.

I've got two test plans, one for testing our application (a)  and one our 
database (b). My test plans have the following structure (really there are 
30 thread groups but the ideas the same)

Tesplan
      Thread group 1
          SimpleController
                For test plan (a) HTTP Request
                For test plan (b) JDBC Requests
 
      Thread group 2
          SimpleController
                For test plan (a) HTTP Requests
                For test plan (b) JDBC Requests
 

The thread groups contain different Config elements depending on the 
testplan; ie for testplan (a) HTTP Request Defaults and HTPP Cookie 
Manager. Whilst for testplan (b) I have JDBC Database login Defaults and 
JDBC Database Connection Pool Defaults. 

The thread groups properties have the forever and scheduler boxes ticked. 
The scheduler configuration has the start and end time are say 10 minutes 
apart but the same for both thread groups. The Duration is left blank, and 
the startup delay is set at 0.5 for thread group 1 and 120 for thread 
group 2. Ie I want the second thread group to start 2 minutes after the 
first and both thread groups to end at the same time.

The tests are automated from an ant script with my resultlog/output format 
set as xml. In my Jmeter properties file I have 
sampleresult.timestamp.start=true.

The confusion comes when I start looking at the results. For testcase (a), 
ie the one with the HTTP requests all looks fine. I start getting the 
second thread group's requests 2 minutes after the first thread group. 
However from testcase (b) there's no delay between thread group 1 and 2. 
I've got a work around, by chaging the starttime for each subsequent 
thread group to be later however I'd like to understand why my startup 
delay wasn't working for me in the JDBC test.

Thanks for your time and help

Greg Peace

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message