jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jake Newren <...@projectdecade.com>
Subject Jmeter-server failure
Date Fri, 19 Aug 2005 21:19:21 GMT
I've been trying to get jmeter-server up and running on a couple of
different linux boxes and on my SuSE boxes I get an exception thrown every
time I try to run this in server mode. I can run the Jmeter gui with no
problem but ther server throws of this exception everytime:

(Running SuSE Linux 9.2 using Java 1.4.2_08)

[Full GC 2539K->492K(249088K), 0.0235450 secs]
Exception in thread "Thread-3" java.lang.NoClassDefFoundError:
org.apache.jmeter.engine.RemoteJMeterEngine not found in [file:./, core:/]
   at java.lang.Class.initializeClass() (/usr/lib/libgcj.so.4.0.0)
   at java.lang.reflect.Field.getLong(java.lang.Class, java.lang.Object)
(/usr/lib/libgcj.so.4.0.0)
   at java.lang.reflect.Field.getLong(java.lang.Object)
(/usr/lib/libgcj.so.4.0.0)
   at java.io.ObjectStreamClass.getClassUID(java.lang.Class)
(/usr/lib/libgcj.so.4.0.0)
   at java.io.ObjectStreamClass.setClass(java.lang.Class)
(/usr/lib/libgcj.so.4.0.0)
   at java.io.ObjectInputStream.readObject() (/usr/lib/libgcj.so.4.0.0)
   at java.io.ObjectInputStream.readObject() (/usr/lib/libgcj.so.4.0.0)
   at gnu.java.rmi.registry.RegistryImpl_Skel.dispatch(java.rmi.Remote,
java.rmi.server.RemoteCall, int, long) (/usr/lib/libgcj.so.4.0.0)
   at 
gnu.java.rmi.server.UnicastServerRef.incomingMessageCall(gnu.java.rmi.server
.UnicastConnection, int, long) (/usr/lib/libgcj.so.4.0.0)
   at 
gnu.java.rmi.server.UnicastServer.incomingMessageCall(gnu.java.rmi.server.Un
icastConnection) (/usr/lib/libgcj.so.4.0.0)
   at 
gnu.java.rmi.server.UnicastServer.dispatch(gnu.java.rmi.server.UnicastConnec
tion) (/usr/lib/libgcj.so.4.0.0)
   at gnu.java.rmi.server.UnicastConnection.run() (/usr/lib/libgcj.so.4.0.0)
   at java.lang.Thread.run() (/usr/lib/libgcj.so.4.0.0)
   at _Jv_ThreadRun(java.lang.Thread) (/usr/lib/libgcj.so.4.0.0)
   at GC_start_routine (/usr/lib/libgcj.so.4.0.0)
   at __clone (/lib/tls/libc.so.6)

I've tried to download a fresh copy of the binary and even got the source
and recompiled it on both machines, and I still get this error. Google isn't
helping out too much either so I'm hoping somebody has seen this before and
solved the problem. Thanx

    - Jake



---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message