jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emyr Tomos <Emyr_To...@westbourne-terrace.com>
Subject Problems with Regular Expression Extractor
Date Mon, 26 Apr 2004 19:02:13 GMT
I am attempting to get a load test going for a webobjects application. 
Webobjects generates a lot of field names and values as well as POST 
actions, so I have been using regexp a lot and it mostly works well except 
for one instance: 
I'm using the regular expression 
select name="(.*)"
to try and get the name field from something like:
select name="0.8.3.17.1.11.2.1.5.1.3.3"
this should match four times for different values of name. 
I have four of these set up, with template values of $1$, $2$, $3$, $4$, 
and each going successively match no. 1, 2, 3, 4. (I don't really 
understand what the template is - the documentation doesn't explain much 
on this so I'm guessing they're a general regexp thing, which I'm kind of 
klutzy at. Anyway $1$ has worked fine for me elsewhere.)
When I try to use the returns to populate the name parts of name value 
pairs something weird happens: 
The first pair disappears entirely - not just the name but the value. 
The rest get the defaults that you would expect if they had failed. 

I have also tried select name="([\d+\.]+\d+)" in the regular expression 
and [\d+\.]+\d+ in the template, in fact whatever I put in the template 
that isn't $1$ seems to become the value of the string (?)
Any ideas? 

Or a pointer to a resource I can use to find out myself? 
I have attached an extract from my jmx file

Regards,

Emyr Tomos

 

 
Mime
View raw message