jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerry S." <jer...@cox.net>
Subject Re[4]: jMeter on Linux PPC
Date Thu, 22 Apr 2004 12:54:22 GMT
Hello All,

  Yes, that was my bad, I was just typing in a hurry was all.

  I did manage to get it working at least somewhat.  Removing all
  additional options except for HEAP allows jmeter to start and run as
  long as you start it from the jmeter/bin directory.  Anywhere else
  and it throws an exception about not finding home/lib.  Ironically
  I do not seem to have this problem on my x86 boxes running Sun jvm
  1.4.2.  I will try and work out some of the IBMJava2 vs SunSDK
  options.  If anyone is intereseted in also seeing the differences,
  you can get IBMJava2 from IBMs site at:
  https://www6.software.ibm.com/dl/lxdk/lxdk-p
  You will want to download the 32-bit xSeries for Intel x86 or 32-bit
  iSeries/pSeries for PowerPC Linux.  I have not tried using the 1.3.1
  yet at all.

  My first concern is getting this all running from the users home
  directory, that should stop the error opening log I am seeing on
  startup right now (failure to write/permission denied because the
  user doesn't have write permission to the installed jmeter bin
  directory.

  Thanks

  jer

Wednesday, April 21, 2004, 6:24:06 AM, you wrote:

BS> JMeter should run on 1.3.1.

BS> By the way, "jmeter -version" is not valid - it should be "jmeter --version"
BS> or "jmeter -v" - but this is not the problem here.

BS> The /home/lib messages look like the script may not have found the correct
BS> JMeter home directory. You may need to define this before starting jmeter.

BS> JMeter *must* be started from the jmeter bin directory, where the jmeter
BS> scripts are stored. 


BS> S
BS> -----Original Message-----
BS> From: peter lin [mailto:jmw00lfel@yahoo.com]
BS> Sent: 21 April 2004 14:16
BS> To: JMeter Users List; Jerry S.
BS> Subject: Re: Re[2]: jMeter on Linux PPC


 
BS> try commenting out all the extra options.
 
BS> that should get rid of the remaining errors
 
BS> peter lin


BS> "Jerry S." <jer_57@cox.net> wrote:
BS> Hello JMeter,

BS> Thanks for the info. I am fairly new to all this so any additional
BS> guidance would be greatly appreciated.

BS> When I tried removing all the -X options I wound up getting:

BS> [jer@MacG3 jer]$ jmeter -version
BS> [ JVMST080: verbosegc is enabled ]
BS> [ JVMST082: -verbose:gc output will be written to stderr ]
BS> java.lang.Throwable: Could not access /home/lib
BS> at org.apache.jmeter.NewDriver.(NewDriver.java:89)
BS> java.lang.Throwable: Could not access /home/lib/ext
BS> at org.apache.jmeter.NewDriver.(NewDriver.java:89)
BS> java.lang.ClassNotFoundException: org.apache.jmeter.JMeter
BS> at java.net.URLClassLoader.findClass(URLClassLoader.java:374)
BS> at java.lang.ClassLoader.loadClass(ClassLoader.java:562)
BS> at java.lang.ClassLoader.loadClass(ClassLoader.java:494)
BS> at org.apache.jmeter.NewDriver.main(NewDriver.java:166)


BS> Doing a java -X results in:

BS> [jer@MacG3 jer]$ java -X
BS> -Xargencoding Allow Unicode escape sequences in args
BS> -Xbootclasspath:
BS> Set search path for bootstrap classes and resources
BS> -Xbootclasspath/a:
BS> Append to end of bootstrap class path
BS> -Xbootclasspath/p:
BS> Prepend in front of bootstrap class path
BS> -Xcheck:jni Perform additional checks for JNI functions
BS> -Xcheck:nabounds Perform additional checks for JNI array operations
BS> -Xcomp Compile all methods on first use (z/OS only)
BS> -Xdisableexplicitgc Disable explicit GCs
BS> -Xdisablejavadump Use system dump rather than java dump on error
BS> -Xgcpolicy[:optthruput]|[:optavgpause]
BS> Control garbage collector behavior
BS> -Xms Set initial Java heap size
BS> -Xmx Set maximum Java heap size
BS> -Xnoclassgc Disable class garbage collection
BS> -Xcompactexplicitgc Run full compaction in every forced GC (System.gc)
BS> -Xnocompactexplicitgc Don't run compaction in any forced GC
BS> -Xnosigcatch Disable JVM recovery code
BS> -Xnosigchain Disable chaining of signal handlers
BS> -Xoptionsfile= File containing JVM options and defines
BS> -Xoss Set maximum Java stack size for any thread
BS> -Xquickstart Improve startup time by delaying compilation
BS> -Xrs Reduce the use of OS signals
BS> -Xrunhprof[:help]|[:=, ...]
BS> Perform heap, cpu, or monitor profiling
BS> -Xrunjdwp[:help]|[:=, ...]
BS> Load debugging libraries for remote debug
BS> -Xss Set maximum native stack size for any thread
BS> -Xverify Enable strict class checking of all class loads
BS> -Xverify:none Disable strict class checking
BS> -Xverify:remote Enable strict class checking of remote class loads
BS> -Xdebug Enable remote debugging
BS> The -X options are non-standard and subject to change without notice.


BS> I commented out all of the -X options in jmeter/bin/jmeter script
BS> except for HEAP. That resulted in the above mentioned stack trace.
BS> I also changed the ARGS= line to:
BS> ARGS="$HEAP $RMIGC $PERM $DEBUG"
BS> DEBUG= to
BS> DEBUG="-verbose:gc"

BS> Everything else was left alone.

BS> I tried setting up Blackdown JVM, but it is only version 1.3.1 and
BS> won't even run on YDL3. Will JMeter run under 1.3.1 at all? IBM
BS> has this version available also. Would it be worth giving it a try?

BS> Thanks,
BS> jer

BS> Wednesday, April 21, 2004, 2:47:46 AM, you wrote:

BS>> Unfortunately, the -X options are not standard across all JVMs...

BS>> You could just try removing the offending ones from the jmeter shell
BS> script
BS>> - this should allow you to use your current JVM.

BS>> The shell script has some comments on what the options are trying to do.
BS>> If the IBM JVM has similar options (but with different names) perhaps
BS> you
BS>> could post the details (here or Bugzilla) so that a new version of the
BS>> script can be produced (might have to be a new script if one can't
BS>> auto-detect the JVM easily).

BS>> The command
BS>> java -X
BS>> should show the list of -X options (that much seems to be relatively
BS>> standard!)

BS>> Sebastian
BS>> -----Original Message-----
BS>> From: Jerry S. [mailto:jer_57@cox.net]
BS>> Sent: 21 April 2004 03:45
BS>> To: JMeter Users List
BS>> Subject: jMeter on Linux PPC


BS>> Hello All,

BS>> Has anyone ever tried to get jmeter running on Linux PPC, namely
BS>> YellowDog 3.0? I am getting the following error when I try to
BS>> launch jmeter. I am running IBMJava2-SDK-ppc-1.4.1-2.0 (latest
BS>> availible from IBM jit enabled.). I am having no problems running
BS>> this version of jmeter on Linux x86 machines with Sun's SDK 1.4.2 or
BS>> Solaris9 machines with Sun's SDK 1.4.2.

BS>> If this is a problem with the IBMJava2, can anyone tell me where to
BS>> get an SDK that will work?

BS>> Thanks
BS>> jer

BS>> [jer@MacG3 jer]$ jmeter -version
BS>> The JVM option is invalid: -XX:NewSize=128m
BS>> [ Unrecognized option: -XX:NewSize=128m ]
BS>> [ JVMCI123: Unable to parse 1.2 format supplied options - rc=-6 ]
BS>> Could not create the Java virtual machine.






-- 
Best regards,
 Jerry

Windows has detected that your mouse has moved, please wait while
Windows reboots for your changes to take effect.

This is Linux Country. On a quiet night, you can hear Windows reboot.


---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message