jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From peter lin <jmw00l...@yahoo.com>
Subject RE: JMeter compatibility with websphere 5.1 with Axis
Date Thu, 01 Apr 2004 15:26:33 GMT
Ok, I see the problem. I should be able to fix it tomorrow. my wsdlHelper expects this format.
 
- <service name="AddressBookService">
- <port name="AddressBook" binding="AddressBookSOAPBinding">
  <soap:address location="http://localhost:2020/soap/servlet/rpcrouter" /> 

  </port>


  </service>
 
Axis produces this instead.
 
- <wsdl:service name="ElmarSearchService">
- <wsdl:port binding="impl:ElmarSearchServicesSoapBinding" name="ElmarSearchServices">
  <wsdlsoap:address location="http://projekt.wifo.uni-mannheim.de/elmar/api/ElmarSearchServices"
/> 

  </wsdl:port>


  </wsdl:service>
 
 





 
peter lin


"SUBRAMANYAM, KALA (SBCSI)" <ks7659@sbc.com> wrote:
Peter, 

I am attaching the sample WSDL I used in my example. 
You can also find other WSDL samples at http://www.xmethods.com

Thanks
Kala


-----Original Message-----
From: peter lin [mailto:jmw00lfel@yahoo.com] 
Sent: Wednesday, March 31, 2004 12:42 PM
To: JMeter Users List
Subject: Re: JMeter compatibility with websphere 5.1 with Axis



Hi kala,


can you send me a sample of the WSDL generated by websphere 5.1?

I wrote the webservice sampler. the handling of the WSDL is very basic
and doesn't use any third party WSDL driver. As long as the necessary
WSDL nodes are present, the sampler will pick up the webmethods.

if you post a sample of the WSDL I will take a look. Most likely the
format is different.

peter lin



"SUBRAMANYAM, KALA (SBCSI)" wrote:
Hi, 

I am using trying to use JMeter 1.9.1 with IBM Websphere 5.1. 
The steps I followed were,
1. Started my web services application on the IBM WAS 5.1 
2. Added a Thread group and a Webservice(SOAP) request (Alpha Code). 
3. Specified the WSDL URL and clicked on the Load WSDL.

Nothing happens.

If I try the same with a WSDL generated in IBM WAS 4.0.3 it gets loaded.
I also increased the JMeter log level to DEBUG, but no error gets
logged. I looked in the Bugzilla and found no known bugs.

Can you tell me how to load WSDL using AXIS.

Any help is appreciated.
Thanks
Kala


---------------------------------
Do you Yahoo!?
Yahoo! Finance Tax Center - File online. File on time.

---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org

---------------------------------
Do you Yahoo!?
Yahoo! Small Business $15K Web Design Giveaway - Enter today
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message