jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerry S." <jer...@cox.net>
Subject Re[2]: jMeter on Linux PPC
Date Wed, 21 Apr 2004 12:56:00 GMT
Hello JMeter,

  Thanks for the info.  I am fairly new to all this so any additional
  guidance would be greatly appreciated.

  When I tried removing all the -X options I wound up getting:

[jer@MacG3 jer]$ jmeter -version
[ JVMST080: verbosegc is enabled ]
[ JVMST082: -verbose:gc output will be written to stderr ]
  <GC[0]: Expanded System Heap by 65536 bytes
java.lang.Throwable: Could not access /home/lib
        at org.apache.jmeter.NewDriver.<clinit>(NewDriver.java:89)
java.lang.Throwable: Could not access /home/lib/ext
        at org.apache.jmeter.NewDriver.<clinit>(NewDriver.java:89)
java.lang.ClassNotFoundException: org.apache.jmeter.JMeter
        at java.net.URLClassLoader.findClass(URLClassLoader.java:374)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:562)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:494)
        at org.apache.jmeter.NewDriver.main(NewDriver.java:166)


  Doing a java -X results in:

[jer@MacG3 jer]$ java -X
    -Xargencoding     Allow Unicode escape sequences in args
    -Xbootclasspath:<directories and zip/jar files separated by :>
                      Set search path for bootstrap classes and resources
    -Xbootclasspath/a:<directories and zip/jar files separated by :>
                      Append to end of bootstrap class path
    -Xbootclasspath/p:<directories and zip/jar files separated by :>
                      Prepend in front of bootstrap class path
    -Xcheck:jni       Perform additional checks for JNI functions
    -Xcheck:nabounds  Perform additional checks for JNI array operations
    -Xcomp            Compile all methods on first use (z/OS only)
    -Xdisableexplicitgc Disable explicit GCs
    -Xdisablejavadump Use system dump rather than java dump on error
    -Xgcpolicy[:optthruput]|[:optavgpause]
                      Control garbage collector behavior
    -Xms<size>        Set initial Java heap size
    -Xmx<size>        Set maximum Java heap size
    -Xnoclassgc       Disable class garbage collection
    -Xcompactexplicitgc   Run full compaction in every forced GC (System.gc)
    -Xnocompactexplicitgc Don't run compaction in any forced GC
    -Xnosigcatch      Disable JVM recovery code
    -Xnosigchain      Disable chaining of signal handlers
    -Xoptionsfile=<file> File containing JVM options and defines
    -Xoss<size>       Set maximum Java stack size for any thread
    -Xquickstart      Improve startup time by delaying compilation
    -Xrs              Reduce the use of OS signals
    -Xrunhprof[:help]|[:<option>=<value>, ...]
                      Perform heap, cpu, or monitor profiling
    -Xrunjdwp[:help]|[:<option>=<value>, ...]
                      Load debugging libraries for remote debug
    -Xss<size>        Set maximum native stack size for any thread
    -Xverify          Enable strict class checking of all class loads
    -Xverify:none     Disable strict class checking
    -Xverify:remote   Enable strict class checking of remote class loads
    -Xdebug           Enable remote debugging
The -X options are non-standard and subject to change without notice.


  I commented out all of the -X options in jmeter/bin/jmeter script
  except for HEAP.  That resulted in the above mentioned stack trace.
  I also changed the ARGS= line to:
  ARGS="$HEAP $RMIGC $PERM $DEBUG"
  DEBUG= to
  DEBUG="-verbose:gc"

  Everything else was left alone.

  I tried setting up Blackdown JVM, but it is only version 1.3.1 and
  won't even run on YDL3.  Will JMeter run under 1.3.1 at all?  IBM
  has this version available also.  Would it be worth giving it a try?

  Thanks,
  jer

Wednesday, April 21, 2004, 2:47:46 AM, you wrote:

BS> Unfortunately, the -X options are not standard across all JVMs...

BS> You could just try removing the offending ones from the jmeter shell script
BS> - this should allow you to use your current JVM.

BS> The shell script has some comments on what the options are trying to do.
BS> If the IBM JVM has similar options (but with different names) perhaps you
BS> could post the details (here or Bugzilla) so that a new version of the
BS> script can be produced (might have to be a new script if one can't
BS> auto-detect the JVM easily).

BS> The command
BS> 	java -X
BS> should show the list of -X options (that much seems to be relatively
BS> standard!)

BS> Sebastian
BS> -----Original Message-----
BS> From: Jerry S. [mailto:jer_57@cox.net]
BS> Sent: 21 April 2004 03:45
BS> To: JMeter Users List
BS> Subject: jMeter on Linux PPC


BS> Hello All,

BS>   Has anyone ever tried to get jmeter running on Linux PPC, namely
BS>   YellowDog 3.0?  I am getting the following error when I try to
BS>   launch jmeter.  I am running IBMJava2-SDK-ppc-1.4.1-2.0 (latest
BS>   availible from IBM jit enabled.).  I am having no problems running
BS>   this version of jmeter on Linux x86 machines with Sun's SDK 1.4.2 or
BS>   Solaris9 machines with Sun's SDK 1.4.2.

BS>   If this is a problem with the IBMJava2, can anyone tell me where to
BS>   get an SDK that will work?

BS>   Thanks
BS>   jer

BS> [jer@MacG3 jer]$ jmeter -version
BS> The JVM option is invalid: -XX:NewSize=128m
BS> [ Unrecognized option: -XX:NewSize=128m ]
BS> [ JVMCI123: Unable to parse 1.2 format supplied options - rc=-6 ]
BS> Could not create the Java virtual machine.




-- 
Best regards,
 Jerry

Windows has detected that your mouse has moved, please wait while
Windows reboots for your changes to take effect.

This is Linux Country. On a quiet night, you can hear Windows reboot.


---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message