jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ramesh J.C" <rkre...@cmcltd.com>
Subject Re: Jmeter Remote testing
Date Tue, 03 Jun 2003 04:18:56 GMT
Thanks for the reply .I failed to mention that as per the user manual ,I
have kept the required classes in the classpath before starting the
rmiregistry. As you  said the error is  logged in jmeter.log at the client
side.The following is an excerpt of it

06/02/2003 11:46:31 AM ERROR - jmeter.engine:  java.rmi.ConnectException:
Connection refused to host: 172.16.16.45; nested exception is:
 java.net.ConnectException: Connection refused: connect
 at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:567)
 at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:185)
 at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:171)

Here 172.16.16.45 is the ip of the remote host . Please help me to overcome
this problem

Rgds
Ramesh

----- Original Message -----
From: <mstover1@apache.org>
To: "Ramesh J.C" <rkreddy@cmcltd.com>
Sent: Monday, June 02, 2003 6:42 PM
Subject: Re: Jmeter Remote testing


> I'd bet there are errors in the jmeter.log file on either the client or
server
> machines.  You didn't specify what your classpath was set to before you
ran
> rmiregistry - it's very important that it be set as specified in the docs.
>
> -Mike
>
> On 2 Jun 2003 at 17:12, Ramesh J.C wrote:
>
> > Hi
> >      I was using jmeter remote testing to create a realistic load to
load test a
> simple web page .I followed the exact steps given in the user manual ,but
it is
> not working.The following are the steps I have performed.
> > 1.started rmiregistry at a jmeter server
> > 2.started jmeter using the following command 'jmeter -s' at the jmeter
server
> > 3.At the jmeter client I have modified the 'jmeter.properties' file and
have
> included the ip address of the jmeter server
> > 4.I have started the jmeter at the client in GUI mode
> > 5.Opened an already existing test plan at jmeter client containing all
the
> elements(this plan was working when it is run without remote host)
> > 6.clicked Run->Remote Start-><IP address of the remote host>
> >
> > But no response is coming i.e the green indicator is not coming and  no
> errors are  coming either at the client side nor at the server
> > Please let me know if I have missed any step or the correct procedure to
> use the remote test feature
> >
> > Rgds
> > Ramesh
> >
> >
> >
>
>
>
> --
> Michael Stover
> mstover1@apache.org
> Yahoo IM: mstover_ya
> ICQ: 152975688
> AIM: mstover777
>


---------------------------------------------------------------------
To unsubscribe, e-mail: jmeter-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jmeter-user-help@jakarta.apache.org


Mime
View raw message