jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Bender" <dben...@umn.edu>
Subject RE: Problems setting up remotely..
Date Wed, 18 Dec 2002 17:59:10 GMT
I had trouble getting this working and discovered that there's an error in
the web page documenation regarding the classpath.  Maybe others caught it
and corrected for it, but it took me four hours of putzing around.  Under
"Step 1" of http://jakarta.apache.org/jmeter/usermanual/remote-test.html,
the docs say:

"...Before running rmiregistry, make sure that the following jars are in
your system claspath:

JMETER_HOME/lib/ext/ApacheJMeter_core.jar
JMETER_HOME/lib/jorphan.jar
JMETER_HOME/lib/logkit-1.0.1

The rmiregistry ..."

The last item, "logkit-1.0.1" should have a ".jar" appended to it.  Again,
the docs say they're all jars, so a person could figure it out, but I didn't
and spent four hours in a lesson about how to pay attention.  I had just
copied and pasted the paths and missed that little detail.

It might be good to correct that oversight.  Not sure how to direct this to
the documentation people or person.  If anyone knows, please advise....


Dave




-----Original Message-----
From: Mike Stover [mailto:mstover1@apache.org]
Sent: Wednesday, December 18, 2002 10:14 AM
To: JMeter Users List
Subject: RE: Problems setting up remotely..


rmiregistry has to be running first, and then start the jmeter server
(jmeter -s).  The system
classpath has to include the appropriate jars for rmiregistry, not for
JMeter.  Also note that
rmiregistry can sometimes leave processes hanging, even when it looks shut
down.  I have in
the past found that rebooting my NT machine to be the only sure way of
clearing such things
out.  If JMeter says rmiregistry is not running, it's pretty good bet it's
right.

-Mike

On 18 Dec 2002 at 10:19, Lawrence, Steve wrote:

> > verify things and then in the same console launch rmiregistry.
>
> Thanks for the help on this. I didn't have a classpath set, and um... now
I
> do.
> [root@000193402-d root]# echo $CLASSPATH
>
/home/lawreste/jakarta-jmeter/lib/ext/ApacheJMeter_core.jar:/home/lawreste/j
>
akarta-jmeter/lib/jorphan.jar:/home/lawreste/jakarta-jmeter/lib/logkit-1.0.1
>
> However, I'm still getting bad calls. I took a peek at the /bin/jmeter.log
> which reports :
>
> 12/18/2002 9:57:52 AM ERROR - jmeter.engine: rmiregistry needs to be
running
> to start JMeter in server mode java.rmi.ServerError: Error occurred in
> server thread; nested exception is:
> 	<blah...>
>
> However.. I *have* started rmiregistry :
>
> root      4316  4149  0 09:57 tty1     00:00:00
> /usr/java/j2sdk1.4.1_01/bin/rmiregistry
>
> I've tried running it plain :
> 1) rmiregistry &
>
> and I've tried explicitly declaring the path to the one from the SDK :
>
> 2) /usr/java/j2sdk1.4.1_01/bin/rmiregistry &
>
> I can see it's running with a netstat -a
>
> tcp        0      0 *:1099                  *:*                     LISTEN
>
> Any ideas on why my Jmeter isn't seeing it?
>
> Steve.
>
>
> --------------------------------------------------------------------------
----
> Notice:  This e-mail message, together with any attachments, contains
information of Merck & Co., Inc. (Whitehouse Station, New Jersey, USA) that
may be confidential, proprietary copyrighted and/or legally privileged, and
is intended solely for the use of the individual or entity named in this
message.  If you are not the intended recipient, and have received this
message in error, please immediately return this by e-mail and then delete
it.
>
>
============================================================================
==
>
>
> --
> To unsubscribe, e-mail:
<mailto:jmeter-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:jmeter-user-help@jakarta.apache.org>
>



--
Michael Stover
mstover1@apache.org
Yahoo IM: mstover_ya
ICQ: 152975688
AIM: mstover777

--
To unsubscribe, e-mail:
<mailto:jmeter-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:jmeter-user-help@jakarta.apache.org>



--
To unsubscribe, e-mail:   <mailto:jmeter-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jmeter-user-help@jakarta.apache.org>


Mime
View raw message