jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wood, Michael" <Michael.W...@schwab.com>
Subject RE: HTTPS broken from 1.7 to 1.7.3
Date Wed, 11 Sep 2002 21:07:53 GMT
It just worked for me too (upgrading to JDK141). I guess it does simplify
the configuration too.

Thanks for getting my testing back up and running.

-----Original Message-----
From: David Anderson [mailto:david.anderson@notiva.com]
Sent: Wednesday, September 11, 2002 1:39 PM
To: JMeter Users List
Subject: RE: HTTPS broken from 1.7 to 1.7.3


I was getting the same error and so I upgraded my JDK to 1.4.1

Not saying this is a great solution to the problem, but it worked in my
case.

Dave

David R. Anderson
Technical Architect - Notiva Corporation
(952)941.8278 ext. 27
(612)963.8263 - (c)
david.anderson@notiva.com



>>-----Original Message-----
>>From: Wood, Michael [mailto:Michael.Wood@schwab.com]
>>Sent: Wednesday, September 11, 2002 2:47 PM
>>To: 'jmeter-user@jakarta.apache.org'
>>Subject: HTTPS broken from 1.7 to 1.7.3
>>
>>
>>Hi,
>> 
>>Have tried searching archives for this. 
>>I had 1.7 release working with our HTTPS only site. I am 
>>using JDK1.3.1 with
>>JSSE 1.0.3. 
>>I tried upgrading to 1.7.3 unstable and also the latest 
>>nightly (9/11) and I
>>get the following:
>> 
>>WARN - jmeter.protocol.http: unknown protocol: https
>>java.net.MalformedURLException: unknown protocol: https
>> at java.net.URL.<init>(URL.java:307)
>> at java.net.URL.<init>(URL.java:224)
>> at
>>org.apache.jmeter.protocol.http.sampler.HTTPSampler.getUrl(HTT
>>PSampler.java:
>>421)
>> at
>>org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTT
>>PSampler.java:
>>872)
>> at
>>org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTT
>>PSampler.java:
>>380)
>> at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:139)
>> at java.lang.Thread.run(Thread.java:484)
>>
>>I did notice that HTTPS support was dropped from HTTP 
>>Defaults in the 9/11
>>build so coded all my HTTP Requests with the HTTPS radio 
>>button and dropped
>>the Defaults.
>> 
>>Here's the properties:
>>ssl.provider=com.sun.net.ssl.internal.ssl.Provider
>>#ssl.provider=iaik.security.jsse.provider.IAIKJSSEProvider
>>ssl.pkgs=com.sun.net.ssl.internal.www.protocol
>>#javax.net.ssl.trustStore=/path/to/cacerts    
>>#ssl.pkgs=iaik.protocol
>>#ssl.provider=com.mycompany.security.provider.SmartProvider
>>#iaik.provider=com.mycompany.security.provider.SmartSSLProvider
>>
>> 
>>I have my own HostnameVerifier that I set in the
>>org.apache.jmeter.untils.JsseSSLManager setContext() method. 
>>It is not even
>>getting there as it appears to not even try the SSL level. 
>> 
>>With 1.7.3 unstable (not the nightly) I get this at startup:-
>>SSL Provider is: SunJSSE version 1.03
>>Secure = false
>>Running the test!
>> (The system cannot find the path specified)
>> 
>>Please advise!!
>>Thanks - very grateful!
>>Mike.
>> 
>> 
>>

--
To unsubscribe, e-mail:
<mailto:jmeter-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:jmeter-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:jmeter-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jmeter-user-help@jakarta.apache.org>


Mime
View raw message