jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hau Koh Foo NCS <kf...@ncs.com.sg>
Subject Weird database test plan behaviour
Date Tue, 10 Sep 2002 00:44:07 GMT

Hi, I have a question. I am using the nightly builds of Jmeter right now. I
used it to build a database test plan, with jmeter on the same machine as
the targetted database, with the following configuration: 

Database url and driver
 ------------------------
 jdbc url: jdbc:oracle:oci8:@stc 
driver class: oracle.jdbc.driver.OracleDriver 

Login Config
 ------------ 
username: stc
 password : password 

Database connection pool
 ------------------------ 
no of connections:1 
Max usage for each connection: 50 
SQL Query: UPDATE accounts set bal = bal + 50 where account_id =1 

When I run it, I get results(as in the listeners are showing
feedbacks)However,when I went to check the database, I found that there isnt
any updates made to my account_id =1. I tested my connection, this time
leaving all the above information empty, ie the login config, database
drivers' information empty, and still my listeners are still responding.
That is, whatever junk I filled in, I still get some feedbacks from
somewhere except from the designated database stc.

Following that, at the command line, I got the following error:

An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : 11 occurred at PC=0xFF35AE24
Function=_pthread_mutex_destroy+0x4
Library=/usr/lib/libthread.so.1

Current Java thread:
	at oracle.jdbc.oci8.OCIDBAccess.do_open(Native Method)
	at oracle.jdbc.oci8.OCIDBAccess.logon(OCIDBAccess.java:354)
	- locked <f1de7e08> (a oracle.jdbc.oci8.OCIDBAccess)
	at
oracle.jdbc.driver.OracleConnection.<init>(OracleConnection.java:249)
	at
oracle.jdbc.driver.OracleDriver.getConnectionInstance(OracleDriver.java:365)
	at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:260)
	at java.sql.DriverManager.getConnection
..............

I suspect it might be OS problem, but I am not sure.
Can anybody tell me where my problem lies? Thnx!

I am using windows 2000,  java version "1.4.0"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.0-b92)
Java HotSpot(TM) Client VM (build 1.4.0-b92, mixed mode)

--
To unsubscribe, e-mail:   <mailto:jmeter-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jmeter-user-help@jakarta.apache.org>


Mime
View raw message