jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Anderson" <david.ander...@notiva.com>
Subject RE: NullPointer when running test
Date Mon, 01 Jul 2002 14:23:27 GMT
Is your login.jsp a HTML form, and if so, what is the action of the form?  If the action posts
to another page or servlet to actually do the authentication, you need to add that as another
HTTP request.

Dave

-----Original Message-----
From: Neal Bridges [mailto:nbridges@providerlink.com]
Sent: Monday, July 01, 2002 9:17 AM
To: JMeter Users List
Subject: RE: NullPointer when running test


If I read your reply correctly, all your saying is change my default request
to go directly to the login.jsp servlet, and then on the HTTP Request, and
only add in the POST information.

If so, I did that and i'm still getting the same NullPointer.  Am I missing
something?

Neal


-----Original Message-----
From: David Anderson [mailto:david.anderson@notiva.com]
Sent: Monday, July 01, 2002 10:08 AM
To: JMeter Users List
Subject: RE: NullPointer when running test


I had problems with authentication as well.  Instead of making the HTTP
reuqest go to the login page directly, I had it do a POST to the target
servlet sending in the username and password.  From then on, all my
subsequent requests worked fine.

Dave

>  -----Original Message-----
> From: 	Neal Bridges [mailto:nbridges@providerlink.com]
> Sent:	Monday, July 01, 2002 8:29 AM
> To:	JMeter Users List
> Subject:	NullPointer when running test
>
> Hello all - Here's the situation - hope you can help.
>
> Wrote a faily simple Test Plan:
>  Thread Group
>     Request defaults
>     Cookie manager
>     Page request
>     File reporter
>
> The request is being made to a secure(https) jakarta web server for an
login.jsp that performs a strut action.  So, my server is set up to
"secure.myserver.com" with the path "/pathname"  then in the Page request, i
request "/login.jsp".  The Thread test sequence is 5 threads at 2 loops.
When I start the test, it appears to run fine in the console window
displaying the program output.  Below is the output of the program:
>
> Sampling url: https://login.providerlink.com/login.jsp
> Sampling url: https://login.providerlink.com/login.jsp
> Sampling url: https://login.providerlink.com/login.jsp
> Sampling url: https://login.providerlink.com/login.jsp
> Sampling url: https://login.providerlink.com/login.jsp
> java.lang.NullPointerException
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.setupConnection(HTTPSamp
ler.java:206)
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:
437)
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:
164)
>         at
org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:138)
>         at java.lang.Thread.run(Unknown Source)
> java.lang.NullPointerException
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.setupConnection(HTTPSamp
ler.java:206)
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:
437)
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:
164)
>         at
org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:138)
>         at java.lang.Thread.run(Unknown Source)
> java.lang.NullPointerException
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.setupConnection(HTTPSamp
ler.java:206)
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:
437)
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:
164)
>         at
org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:138)
>         at java.lang.Thread.run(Unknown Source)
> java.lang.NullPointerException
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.setupConnection(HTTPSamp
ler.java:206)
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:
437)
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:
164)
>         at
org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:138)
>         at java.lang.Thread.run(Unknown Source)
> java.lang.NullPointerException
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.setupConnection(HTTPSamp
ler.java:206)
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:
437)
>         at
org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:
164)
>         at
org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:138)
>         at java.lang.Thread.run(Unknown Source)
>
> From the looks of it, it samples the URL the first 5 times without a
problem, but then you get the NullPointer on the second set of threads.  The
onlything written to the file reporter is as follows:
>
>
> # Sample data created by null
>
> #       URL                    Milliseconds>
>
> So, that's my quandry.  Any insite into this would be most appreciated.
>
> Kindest Regards,
> Neal Bridges
> Providerlink, Inc.
> http://www.providerlink.com
> nbridges@providerlink.com
>  << File: ATT189881.txt >>

--
To unsubscribe, e-mail:
<mailto:jmeter-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:jmeter-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:jmeter-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jmeter-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:jmeter-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jmeter-user-help@jakarta.apache.org>


Mime
View raw message