jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Trahan, Randall S (Randall)" <tra...@avaya.com>
Subject RE: running JMeter on Linux
Date Fri, 14 Jun 2002 17:19:20 GMT
Bill,

It looks like no one responded to you.  I just saw your post.  I am running RH 7.2, also.
 I had the same problem.  I had to load an earlier version (I also tried the latest beta version)
and Jmeter ran fine.

Good luck,
Randy Trahan


-----Original Message-----
From: bill giebink [mailto:giebink@banana.ifa.hawaii.edu]
Sent: Friday, June 07, 2002 9:00 PM
To: jmeter-user@jakarta.apache.org
Subject: running JMeter on linux


I cannot get JMeter to run on Redhat 7.2. There is a working Java 
install (j2sdk-1.4.0). I have tried searching the web, user groups, and 
the archives but have seen nothing. I have also asked a (reluctant) 
coworker. Below is what I've tried.

With the command:
$/bin/sh jmeter
jmeter: : command not found
jmeter: : command not found
jmeter: line 9: syntax error near unexpected token `in'
jmeter: line 9: `     case $x in'

With only the java command written into a script and executed:
java -classpath 
$PATH:$CLASSPATH:/usr/local/jakarta-jmeter/lib/ant-1.4.1.jar:/usr/local/jakarta-jmeter/lib/jakarta-ant-1.4.1-optional.jar:


/usr/local/jakarta-jmeter/lib/jakarta-oro-2.0.1.jar:/usr/local/jakarta-jmeter/lib/junit.jar:/usr/local/jakarta-jmeter/lib/log4j-core.jar:


/usr/local/jakarta-jmeter/lib/log4j.jar:/usr/local/jakarta-jmeter/lib/Tidy.jar:/usr/local/jakarta-jmeter/lib/util.jar:


/usr/local/jakarta-jmeter/lib/xerces.jar:/usr/local/jakarta-jmeter/bin/ApacheJMeter.jar:.


-D/usr/local/jakarta-jmeter/bin/log4j.conf org.apache.jmeter.NewDriver 
/usr/local/jakarta-jmeter/bin/jmeter.properties

Exception in thread "main" java.lang.NullPointerException
   at java.io.Reader.<init>(Reader.java:61)
   at java.io.InputStreamReader.<init>(InputStreamReader.java:80)
   at java.util.Properties.load(Properties.java:189)
   at 
org.apache.jmeter.util.JMeterUtils.getProperties(JMeterUtils.java:123)
   at org.apache.jmeter.NewDriver.main(NewDriver.java:85)

Assistance is greatly appreciated.
Bill




--
To unsubscribe, e-mail:   <mailto:jmeter-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jmeter-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:jmeter-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jmeter-user-help@jakarta.apache.org>


Mime
View raw message